Reply
Contributor
Posts: 52
Registered: ‎2007-05-26

ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I have had a running battle trying to get consistent archiving from from Tivo (Premier XL) to ReadyNas Ultra 6 plus - for a while it seemed to mostly work but since July it only very rarely works with only about 5 successful archive attempts since that time, one as recently as Dec 2nd.

My Ultra 6 Plus is now running new firmware image. (RAIDiator-x86 4.2.19) which I updated today while trying to reset both the Tivo and ReadyNAS. I have rebooted both and launched several attempts of archive but same issues remain.

I have been searching the forum and see that others have problems with files not properly recognized as KUID. Noting these similar problems, but I did not seem to find a post with any solution I will try to state my situation here.

My logs show many many listings such as this today, each and every day it tries to archive:

[2011/12/20 18:01:10] tivo_utils.c:249: info: Modern Family (Two Monkeys and a Panda) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

this entry is repeated for virtually everything on my Tivo currently. Very strange, but today was the first time I looked at the Tivo log as I did not know one existed until seeing the other posts I simply thought the ReadyNAS and Tivo did not connect at all.

I checked the Tivo and this program is clearly marked KUID (Keep until I delete) and should be archived. I managed to get some shows archived on Dec 2nd and Nov 25th but no matter what I mark KUID on the TIVO box does not seem to matter - the archive simply skips over it.

I have RAIDar 4.3.0 and all "lights" on the RAIDar are Green. I can also see and play any archived files on Tivo or my mac. Just can't seem to add any new shows.

Under the Streaming Services tab / ReadyDLNA it shows v1.0.22 not sure if this is current or how to update?

Any other info needed to troubleshoot?

Any ideas on how to fix as I am running out of disk space on the Tivo?

Thanks!
Initial Contributor
Posts: 1
Registered: ‎2011-12-20

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

ReadyMark,

I'm experiencing the same problems as you. ReadyNas Ultra 4 w/ RAIDiator 4.2.19 which includes readytivo 1.3.7 and readydlna 1.0.22. I have two TiVo's. A Series 3 HD and a TiVo Premier.

Videos from both TiVo's that are KUID show up with logs like the following when the ReadyNas attempts to archive them:
[2011/12/20 22:49:21] tivo_utils.c:249: info: Bones (The Male in the Mail) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

The file is KUID on the TiVo, and the database does not list that program id (I've used prune.txt to wipe the database clean and have verified that the database is empty via manual sqlite3 commands run from a different box on the db file)

One theory is that perhaps it is a TiVo update that broke readytivo here? Maybe in the past the TiVo's would set KUID expiration dates to a specific value (say, 2050) and a TiVo update changed it so that KUID values are now set to 2038. And if readytivo was checking with logic like "If expiration date is > 2049 then this is KUID". But if TiVo changed the KUID date to be earlier, now readytivo no longer views that as KUID.

The logic is in tivo_utils.c... If I could see the source code, perhaps I could find out more. Any chance we can get source here?
Contributor
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Thanks for confirming I am not alone. Perhaps others can help. Maybe we should post to Tivo Community but I have not seen much on ReadyNAS problems there.

Any help out there would help us both.

Thanks!
Contributor
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Anybody have any ideas or suggestions on next steps to try?

Thanks,
Mark
Contributor
Posts: 33
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Same issue as you....contracted Tech Support a while ago and am making little to no progress.

Very Frustrating....Fix the Damn problem!!!!
Contributor
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Yes I have an ongoing ticket. Tried a few of their suggestions (re-install ReadyTivo 1.3.1 x86 - but it was not accepted with error: This update is unnecessary with this firmware version. Ugh...

Now they want me to try an perform OS reinstall. I don't want to do this until I do a backup - so that will take awhile. To make matters worse I had a disk failure - a new drive is currently going thru re-sync.

Then I will backup and try OS reinstall and let you know how that works.
Contributor
Posts: 33
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I did the Firmware reinstall and the Beta Firmware install....also downgraded ReadyTivo and then upgraded....

I have three Tivo's (2 Series 3's and 1 Elite), the Series 3's archive fine, the Elite has the problem. This problem has been reported by a few folks and I'm not aware of anyone who has had it fixed.

Ugh...
Occasional Contributor
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I can report similar behavior:

ReadyNas: Ultra2 running RAIDiator 4.2.19 and ReadyTiVo 1.3.7
Tivo#1: Tivo Series 3 HD
Tivo#2 Tivo Premere

I can reliably archive KUID shows to the ReadyNas from Tivo#1, but the shows from Tivo#2 are never archived.

Looking at the logs from ReadyNas, i see similar results as posted by others in this thread, where newer Tivos log the KUID shows with the date 2038-01-19:

[2011/12/30 17:00:19] tivo_utils.c:249: info: Dr. Seuss' How the Grinch Stole Christmas ((null)) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.
[2011/12/30 17:00:21] tivo_utils.c:249: info: The Late Late Show With Craig Ferguson (Actor Seth Rogen; actress Judy Greer) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.


I've logged a ticket to customer support. Have recieved no response yet.
Contributor
Posts: 32
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I am here hoping to resolve my similar issue that has recently appeared. Archiving had been working well, but now no KUIDs are getting archived.

Where do you find the version of ReadyTiVo?

How do you view the log that mentions KUIDs?

Thanks in advance for any useful info.

ReadyNAS Ultra 2 Plus
RAIDiator 4.2.20-T4
ReadyDLNA v1.0.22

Tivo Premiere, sw v14.9.2.2-01-2-748
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Occasional Contributor
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Hi denarius,

You can easily retrieve the ReadyTivo logs via the FrontView web interface. On the right hand FrontView menu, choose "Status" and then "Logs". In the upper right corner of the logs window, click on "Download All Logs". This will download a zip which you can unzip locally and will contain various log files, including "readytivo.log". That log will contains the KUID dates as well as the version of ReadyTivo.
Discussion Stats
Top Contributors
User Kudos Count
41
28
16
10
2