Reply
Aspirant
Posts: 52
Registered: ‎2007-05-26

ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I have had a running battle trying to get consistent archiving from from Tivo (Premier XL) to ReadyNas Ultra 6 plus - for a while it seemed to mostly work but since July it only very rarely works with only about 5 successful archive attempts since that time, one as recently as Dec 2nd.

My Ultra 6 Plus is now running new firmware image. (RAIDiator-x86 4.2.19) which I updated today while trying to reset both the Tivo and ReadyNAS. I have rebooted both and launched several attempts of archive but same issues remain.

I have been searching the forum and see that others have problems with files not properly recognized as KUID. Noting these similar problems, but I did not seem to find a post with any solution I will try to state my situation here.

My logs show many many listings such as this today, each and every day it tries to archive:

[2011/12/20 18:01:10] tivo_utils.c:249: info: Modern Family (Two Monkeys and a Panda) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

this entry is repeated for virtually everything on my Tivo currently. Very strange, but today was the first time I looked at the Tivo log as I did not know one existed until seeing the other posts I simply thought the ReadyNAS and Tivo did not connect at all.

I checked the Tivo and this program is clearly marked KUID (Keep until I delete) and should be archived. I managed to get some shows archived on Dec 2nd and Nov 25th but no matter what I mark KUID on the TIVO box does not seem to matter - the archive simply skips over it.

I have RAIDar 4.3.0 and all "lights" on the RAIDar are Green. I can also see and play any archived files on Tivo or my mac. Just can't seem to add any new shows.

Under the Streaming Services tab / ReadyDLNA it shows v1.0.22 not sure if this is current or how to update?

Any other info needed to troubleshoot?

Any ideas on how to fix as I am running out of disk space on the Tivo?

Thanks!
Aspirant
Posts: 1
Registered: ‎2011-12-20

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

ReadyMark,

I'm experiencing the same problems as you. ReadyNas Ultra 4 w/ RAIDiator 4.2.19 which includes readytivo 1.3.7 and readydlna 1.0.22. I have two TiVo's. A Series 3 HD and a TiVo Premier.

Videos from both TiVo's that are KUID show up with logs like the following when the ReadyNas attempts to archive them:
[2011/12/20 22:49:21] tivo_utils.c:249: info: Bones (The Male in the Mail) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.

The file is KUID on the TiVo, and the database does not list that program id (I've used prune.txt to wipe the database clean and have verified that the database is empty via manual sqlite3 commands run from a different box on the db file)

One theory is that perhaps it is a TiVo update that broke readytivo here? Maybe in the past the TiVo's would set KUID expiration dates to a specific value (say, 2050) and a TiVo update changed it so that KUID values are now set to 2038. And if readytivo was checking with logic like "If expiration date is > 2049 then this is KUID". But if TiVo changed the KUID date to be earlier, now readytivo no longer views that as KUID.

The logic is in tivo_utils.c... If I could see the source code, perhaps I could find out more. Any chance we can get source here?
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Thanks for confirming I am not alone. Perhaps others can help. Maybe we should post to Tivo Community but I have not seen much on ReadyNAS problems there.

Any help out there would help us both.

Thanks!
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Anybody have any ideas or suggestions on next steps to try?

Thanks,
Mark
Guide
Posts: 47
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Same issue as you....contracted Tech Support a while ago and am making little to no progress.

Very Frustrating....Fix the Damn problem!!!!
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Yes I have an ongoing ticket. Tried a few of their suggestions (re-install ReadyTivo 1.3.1 x86 - but it was not accepted with error: This update is unnecessary with this firmware version. Ugh...

Now they want me to try an perform OS reinstall. I don't want to do this until I do a backup - so that will take awhile. To make matters worse I had a disk failure - a new drive is currently going thru re-sync.

Then I will backup and try OS reinstall and let you know how that works.
Guide
Posts: 47
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I did the Firmware reinstall and the Beta Firmware install....also downgraded ReadyTivo and then upgraded....

I have three Tivo's (2 Series 3's and 1 Elite), the Series 3's archive fine, the Elite has the problem. This problem has been reported by a few folks and I'm not aware of anyone who has had it fixed.

Ugh...
Aspirant
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I can report similar behavior:

ReadyNas: Ultra2 running RAIDiator 4.2.19 and ReadyTiVo 1.3.7
Tivo#1: Tivo Series 3 HD
Tivo#2 Tivo Premere

I can reliably archive KUID shows to the ReadyNas from Tivo#1, but the shows from Tivo#2 are never archived.

Looking at the logs from ReadyNas, i see similar results as posted by others in this thread, where newer Tivos log the KUID shows with the date 2038-01-19:

[2011/12/30 17:00:19] tivo_utils.c:249: info: Dr. Seuss' How the Grinch Stole Christmas ((null)) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.
[2011/12/30 17:00:21] tivo_utils.c:249: info: The Late Late Show With Craig Ferguson (Actor Seth Rogen; actress Judy Greer) is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping.


I've logged a ticket to customer support. Have recieved no response yet.
Aspirant
Posts: 33
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I am here hoping to resolve my similar issue that has recently appeared. Archiving had been working well, but now no KUIDs are getting archived.

Where do you find the version of ReadyTiVo?

How do you view the log that mentions KUIDs?

Thanks in advance for any useful info.

ReadyNAS Ultra 2 Plus
RAIDiator 4.2.20-T4
ReadyDLNA v1.0.22

Tivo Premiere, sw v14.9.2.2-01-2-748
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Aspirant
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Hi denarius,

You can easily retrieve the ReadyTivo logs via the FrontView web interface. On the right hand FrontView menu, choose "Status" and then "Logs". In the upper right corner of the logs window, click on "Download All Logs". This will download a zip which you can unzip locally and will contain various log files, including "readytivo.log". That log will contains the KUID dates as well as the version of ReadyTivo.
Aspirant
Posts: 33
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Thanks a lot, Jack, much obliged.
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Aspirant
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Link this thread to two other theads describing two similar problems with ReadyNAS support for Tivo:

BUG#1: ReadyNAS will sometimes disappers from Tivos "My Shows". This bug is intermittent, but seems to occur on all Tivos (HD, Premere, and Elite).
http://www.readynas.com/forum/viewtopic.php?f=76&t=53573

BUG#2: Failure to Archive KUID shows on Tivo Premere and Tivo Elite. Archive appears to work on Tivo HD.
http://www.readynas.com/forum/viewtopic.php?f=76&t=58343

I have an open case# with Tech Support team. Can anyone confirm they are still seeing either of these issues, or confirm a reliable workaround?
Aspirant
Posts: 33
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I'm not seeing Bug#1, but continue to see Bug#2 on my Premiere.

Like yours, my log shows: "is no longer KUID (expires 2038-01-19T03:14:00Z). Skipping." The theory given by pmyers sounds right to me:

pmyers wrote:
One theory is that perhaps it is a TiVo update that broke readytivo here? Maybe in the past the TiVo's would set KUID expiration dates to a specific value (say, 2050) and a TiVo update changed it so that KUID values are now set to 2038. And if readytivo was checking with logic like "If expiration date is > 2049 then this is KUID". But if TiVo changed the KUID date to be earlier, now readytivo no longer views that as KUID.
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Well today, as requested by NetGear support I re-installed the OS and then re-launched a Tivo request but still get the same errors with the 2038 KUID issue discussed above.

Very frustrating. I have a ticket open and will report what happened after the OS re-install and see what else they suggest.
Guide
Posts: 47
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

The problem is that tech support is handling this like an individual configuration issue. It is very clear that the Premiere and Elite have an issue with Archiving (the KUID error). I have asked my support person multiple times if this is a confirmed issue and do not get a response. "Have you tested this with either a Premiere or Elite?".....no response.

Again, my situation, both Series 3 Tivos archive just fine....the Elite doesn't.
Aspirant
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I am getting some traction with Tech Support team; they have agreed to forward the KUID issue to the engineering department. Once the engineers get back from holiday break, I think the only solution would be if engineering can offer an updated executable (readytivod) with support for Premiere/Elite.

Skywalker, you are our only hope.
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

That is good news. At least someone seems to recognize this as a more global problem not individual user issue.

Thanks for pushing this along.
Guide
Posts: 47
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Hopefully this will get resolved quickly. It should be real easy to duplicate the issue....

Maybe if we stick together and keep working with Tech Support we can get this resolved.
Aspirant
Posts: 33
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

jackohound, has engineering given this any attention?
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Aspirant
Posts: 13
Registered: ‎2011-12-30

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Engineering is showing some attention. I was contacted on 05-Jan and asked to provide some more logs and setup my ReadyNas so Netgear can remotely access it. I've provided everything they asked for and am awaiting further direction

As others have stated here, I'm disappointed in the Tech Support response so far. Since we are seeing consistent results, it should be easy for QA or Engineering departments to reproduce the issue locally. So far, they have not confirmed whether they can (or cannot) reproduce the reported issue, or if they have in fact tested with a Tivo Premiere or Elite. Simply acknowledging the current bug with Tivo Premeire/Elite would be a good first step.

In parallel, i am exploring an alternative open source solution (Galleon http://galleon.sourceforge.net/index.php?option=com_content&task=view&id=94&Itemid=53). I have the app installed and running on ReadyNAS. Not all features are working yet, but it might just be configuration issues. There are pros and cons to both Galleon and ReadyTivo. Anyone interested in helping to get Galleon ported/installed on their ReadyNAS? You need to enable ssh on your ReadyNAS and be comfortable with basic linux commands, and be willing to experiment with different settings so we arrive at a working stable solution for ReadyNAS. If so, i'll start another thread to discuss Galleon details.
Aspirant
Posts: 52
Registered: ‎2007-05-26

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I am about in the same boat as Jackohound with exception of Galleon option. Provided logs, working on getting them remote access to my ReadyNas Ulta 6. I am not as technically adept as you, so the remote access was a bit of a challenge and now I am traveling and will try again when I return.
Guide
Posts: 47
Registered: ‎2008-05-14

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

I'm also on the same boat (maybe we should meet for drinks!). I travel a lot and the remote access thing was a bit too complicated and time consuming. I'm not really thrilled about giving someone else access to my system when I cannot watch....

I honestly don't understand why they cannot duplicate the problem in the lab...I have asked them directly "have you gotten this to work in the lab" and don't get a response.

Support has really taken a dive in the past year or so. I'm just about done with their products.
Aspirant
Posts: 13
Registered: ‎2010-02-11

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Just to chime in...I am having the same issue. No archive from Elite, THD works fine.
Guide
Posts: 9
Registered: ‎2010-02-01

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Also having ReadyNas Ultra 6 not archiving TiVo Premiere XL problem.

When I first set it up, I did get several shows recorded on the ReadyNas from 10/21/11 through 12/13/11, but nothing since. Nothing has changed on my network; the ReadyNas device still shows up in the TiVo menu and I can transfer the previously recorded shows back to the TiVo, but the ReadyNas device is no longer backing up shows that are marked as "Save until I delete".

Apparently this is a problem many are having. Does anyone have any help on how to resolve this? It did work for almost two months. Is it possible TiVo updated their software and broke something in the ReadyNas process?

P.S. I also have a second, older TiVo unit on my network. A Pioneer DVR810H. I also have some shows from that unit that were recorded to the ReadyNas Ultra 6 during the date range listed above, but nothing since. I can transfer shows that are on the Pioneer TiVo to the Premiere XL TiVo, so the network seems to be fine. I suspect the ReadyNas software is somehow not firing.
Aspirant
Posts: 33
Registered: ‎2011-09-13

Re: ReadyNAS Ultra 6 Tivo Not Archiving -- KUID problem?

Yep, it seems very likely that Tivo changed how they indicate KUID, and that something on the ReadyNAS side has to change because of that. Can't help thinking that 15 minutes of quality time from an engineer would identify the problem, 15 minutes of engineering team discussion could identify a good solution, 15 minutes on the forum could acknowledge the problem and announce the expected solution, then we'd just wait for it to fit into an update release cycle. Or I could have it all wrong. Either way, all I can do is wait. In my experience, the wheels of ReadyNAS support turn very slowly.
ReadyNAS NV+ v2, RAIDiator 5.3.6, 4x3T Seagate ST3000DM001-9YN166 fw CC4H, X-RAID2, 256MB RAM, UPS APC BE550G ||| ReadyNAS Ultra 2+, RAIDiator 4.2.20-T4, 2x3T Hitachi HDS5C3030ALA630, X-RAID2, 1024MB RAM, UPS CyberPower CP550SLG
Discussion Stats
Top Contributors