Reply
Highlighted
Tutor

CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Anyone else notice issues with the Netgear CM1150V running on Comcast with the V2.02.x firmware? Particularlly with LACP/LAGG (IEEE 802.3ad) Ethernet Port Aggregation Enabled?

 

I have noticed this since this feature was introduced...

 

If I have LACP/LAGG enabled in the advanced settings on the router connected to my Firewall (OPNSense Virtual Applicance with Intel I350 NIC) all will be fine for a while.  Then a few hours later (not sure exact amount) the internet speed will DRAMATICALLY drop for download. Upload is not affected. 

 

So I will have 950Mbps Down by 45Mbps Up on Comcast DOCSIS 3.1 Gigabit service on immediate power up of the modem, then half way through the day the download will drop to around 25-30Mbps and the upload will remain higher than the download around its 45Mbps mark. 

 

This is reproduceable everytime... I even went as far to buy a Motorola SB8200 for testing (but doesn't support voice) and enabled LACP - works fine for the week of testing at full speed with LACP without issue (Firewall config not touched in anyway).  Also on the Netgear CM1150V if you disable Ethernet Port Aggregation the speeds will remain at their high 950Mbps or so mark.  So their is a bug in Netgears LACP firmware implementation on this Modem which needs to be addressed.

Model: CM1150V|DOCSIS 3.1 Nighthawk® Multi-Gig Speed Cable Modem for XFINITY® Voice
Message 1 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Is your firewall LAG supporting and you have it enabled and connected using both LAN ports for LAG with the modem?

 

Others are seeing similar issues:

https://community.netgear.com/t5/Cable-Modems-Routers/CM1200-slows-down-after-24-48-hours-of-uptime-...


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Yes- everything is configured correctly in terms of LACP/LAGG and using both ports. As I mentioned, the Motorola modem didn't have this issue with same configuration. It most likely isn't on the firewall end of things.

Comcast discussion thread link, found another user with same issue with same modem and firmware:

https://forums.xfinity.com/t5/Your-Home-Network/Netgear-CM1150V-Extreme-Slow-Downs/td-p/3255727
Message 3 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

I believe NG is aware of this issue. Something to contact them about if you feel the need. No idea if or when it will be fixed.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 4 of 75
Highlighted
NETGEAR Employee

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

we are aware of this issue and are testing a fix with a a tester. So far the result is positive.

 

We will plan to send the Firmware to Comcast for certification once our testing is testing is complete.

 

current workaround is to run without LAG enabled.

Message 5 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Can I get the beta firmware to test also? Feel free to message me, if yes.
Message 6 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Thanks for the info. Can you post when the new Comcast firmware is available? I’ve had the modem unhooked in favor of my Motorola MB8600 since this happened.
Message 7 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

FW will be sent to your ISP then pushed from there. I would contact your ISP and ask them if they have any information from NG regarding this issue. Cable modem FW will only be sent to ISPs first so they can test and make sure it works on there network. 


@YoungSpicket wrote:
Thanks for the info. Can you post when the new Comcast firmware is available? I’ve had the modem unhooked in favor of my Motorola MB8600 since this happened.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 8 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Any updates on an ETA for this? I'd be happy to help test out on Comcast if possible.

Message 9 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

@vkdelta 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 10 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

FW will be sent to your ISP then pushed from there. I would contact your ISP and ask them if they have any information from NG regarding this issue. 


@couchgate wrote:

Any updates on an ETA for this? I'd be happy to help test out on Comcast if possible.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 11 of 75
Highlighted
Aspirant

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

I wanted to purchase this same model with service on Xfinity/Comcast and wanted to follow-up with you. Have you received the software update from Comcast that now works for the LACP? Thanks.

Message 12 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

For what its worth, I am still on V2.02.04 with Xfinity.

Message 13 of 75
Highlighted
Initiate

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Just to keep this alive, I am anxiously awaiting this FW fix as well.  Can we get an update from Netgear?  Has the fixed FW been turned over to Comcast?

Message 14 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Waiting for Firmware as well and having the same issue.

 


@AuxNuke wrote:

Just to keep this alive, I am anxiously awaiting this FW fix as well.  Can we get an update from Netgear?  Has the fixed FW been turned over to Comcast?


 

Model: CM1150V|DOCSIS 3.1 Nighthawk® Multi-Gig Speed Cable Modem for XFINITY® Voice
Message 15 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Does anyone know if the CM1200 has this issue as well? Paitently waiting a firmware update from Xfinity for the CM1150V....

Message 16 of 75
Highlighted
Guru

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

LAG is fully enabled on the CM1200. 


@couchgate wrote:

Does anyone know if the CM1200 has this issue as well? Paitently waiting a firmware update from Xfinity for the CM1150V....


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 17 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

@vkdelta 

Still seeing firmware Comcast V2.02.04 in my modem. I'd contact Comcast and ask them to push the new one, if they had it. Do they? Just wondering if testing has been verified and a new firmware sent to Comcast yet?

 

Thanks!

Model: CM1150V|DOCSIS 3.1 Nighthawk® Multi-Gig Speed Cable Modem for XFINITY® Voice
Message 18 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

@CivHunter from what I have gathered, Netgear has given the new firmware to Comcast but Comcast has not pushed it out to customer modems yet. I haven't tried to contact them to ask about it though.

Message 19 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Pretty ridiculuous that the only reason why I bought the Netgear Modem 1150v ($299) and the nighthawk router x80 was to take advantage of the 1g+1g speed rate and can't even do that because of a firmware that is available but Comcast has not released it yet. I should be getting at least 900+ mbps but instead getting 500mbps when i want 2gbps.

Model: CM1150V|DOCSIS 3.1 Nighthawk® Multi-Gig Speed Cable Modem for XFINITY® Voice
Message 20 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03


@estradadad wrote:

Pretty ridiculuous that the only reason why I bought the Netgear Modem 1150v ($299) and the nighthawk router x80 was to take advantage of the 1g+1g speed rate and can't even do that because of a firmware that is available but Comcast has not released it yet. I should be getting at least 900+ mbps but instead getting 500mbps when i want 2gbps.


You won't see 2Gbps even with Lag, you might see the over provision that Comcast does add but more then likely you won't even see that.

Message 21 of 75
Highlighted
Tutor

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

@estradadad With my setup, I see ~930 mbps with regular single-link, and 1250 mbps or so with LAG (before it slows down due to this bug). That's just due to Comcast over-provisioning gigabit speed. You won't see 2 gbps unless you pay for that plan.

Message 22 of 75
Highlighted
Aspirant

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Netgear, can you confirm you have sent the new firmware with the bug fix to Xfinity/Comcast?

Message 23 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

They already confirmed and apparently Xfinity Comcast is sitting with the firmware but haven't pushed it out to their customers.
Message 24 of 75
Highlighted

Re: CM1150V LACP LAGG Firmware Issue - Comcast V2.02.04 and V2.02.03

Fine but I'm seeing half of what I'm supposed to see
Message 25 of 75
Top Contributors
Discussion stats
Announcements