Diskussionsstatistiken
  • 10 Antworten
  • 241 Aufrufe
  • 0 Kudos
  • 2 in Unterhaltung
Autoren, für die die meisten Kudos vergeben wurden
Antworten
Highlighted
Aspirant

Anleitung Erkennung Performance Bottleneck

Hallo,

 

ich habe zwei identische RNS102 mit jeweils zwei WD Red 4TB im Raid 1 Verbund (gerade aufgerüstet). Ziel ist es, einen der beiden an einer anderen Location aufzustellen (beide Locations hängen mit 400MB am Internet) und dann alles Shares per RSYNC regelmäßig zu synchronisieren.

 

Aktuell hängen beide an einem GbE Switch, reporten mir auch jeweils die aktive GbE Verbindung unter Netzwerk. Eines der beiden ist fertig aufgesetzt, die RSYNC Jobs sind auf diesem alle aufgesetzt (remote: RSYNC Server) und laufen gerade zum ersten Mal als vollständige Sicherung. Das Ganze dauert jetzt schon elend lange (ein paar Tage) und die Oberfläche des ausführenden NAS zeigt mir, wenn ich den Mauszeiger bei dem Job, der gerade ausgeführ wird, auf "wird ausgeführt" bewege, eine Geschwindigkeit von lediglich 313kByte/S...

 

Gibt es irgendwo eine gute Schritt für Schritt Anleitung, wie man Performanz Probleme beim ReadyNAS analysiert / behebt? 

 

Vielen Dank schon mal für jeden Hinweis!

Dirk

Nachricht 1 von 11
Highlighted
NETGEAR Moderator

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Dirk_,

 

Es könnte gegebenfalles daran liegen, dass Sie auf beiden ReadyNASs IPv6 nutzen. Hierzu der entsprechende Artikel: https://kb.netgear.com/30047/ReadyNAS-OS-6-IPv6-performance-on-ReadyNAS-100-2120-series

 

Mit freundlichen Grüßen,

Ioannis

NETGEAR Team 


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 2 von 11
Highlighted
Aspirant

Re: Anleitung Erkennung Performance Bottleneck

Hallo Ioannis,

 

Danke erstt einmal für das schnelle Feedback. Ich habe ein privates IPV4 Netzwerk. Bei beiden NAS waren aber IPV4 und IPV6 enabled. Ich habe aufgrund Ihres Feedbacks jetzt bei beiden NAS IPV6 disabled, sehe aber leider keine Aenderungen bei den schlechten Datenraten...

 

Noch eine Idee ?

 

Viele Grüße

Dirk

Nachricht 3 von 11
Highlighted
NETGEAR Moderator

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Dirk_,

 

dann sollten Sie ein OS-Reinstall durchführen, hierbei werden Ihre Daten unberührt bleiben, nur das Admin-Password und Netwerkeinstellungen werden zurückgesetzt. Die genaue anleitung finden Sie, unter: http://www.downloads.netgear.com/files/GDC/READYNAS-100/ReadyNAS_%20OS6_Desktop_HM_EN.pdf , Seite 21 und folgend.

 

Mit freundlichen Grüßen,

Ioannis

NETGEAR Team 


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 4 von 11
Highlighted
Aspirant

Re: Anleitung Erkennung Performance Bottleneck

Hallo Ioannis,

 

Danke für Deinen Hinweis/Vorschlag.

 

Ich habe eine aufwendige Multisite Drupal Installation (installiert initial als Version 1.0.0 von Poussin über Anwendungen, dann aber von mir handisch immer auf diue neueste Drupal 7 Version aktualisiert) mit mehreren Datenbanken darauf laufen, sowie einen konfigurierten Logitech Media Server (Version von nas-tools installiert auch über Anwendungen). Ebenso habe ich über ssh einen tftpd Server (dnsmasq) aufgesetzt. Sind diese Programme und ihre Einstellungen dann alle weg?

 

Grüße

Dirk

Nachricht 5 von 11
Highlighted
NETGEAR Moderator

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Dirk_,

 

Ihre Installationen sollten unberührt bleiben! Smiley (fröhlich)

 

Mit freundlichen Grüßen,

Ioannis

NETGEAR Team 


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 6 von 11
Highlighted
Aspirant

Re: Anleitung Erkennung Performance Bottleneck

Hallo Ioannis,

 

ich hatte, nachdem ich IPV6 auf beiden ReadyNAS disabled hatte, noch keinen Restart der beiden Boxen vorgenommen. Das habe ich jetzt nach Fertigstellung eines Full-Backup Jobs getan. Beim aktuellen Full-Backup Job wird mir jetzt eine Geschwindigkeit (für die RSYNC-Server basierte Full Synchronisierung) von 2-4 Mbyte/s angezeigt. Ist das eine zu erwartende (zugegebener Maßen recht niederige) Geschwindigkeit? Ich habe gelesen RSYNC ist bei einer Vollsicherung sehr CPU intensiv? Oder müsste ich hier auf höhere Datenraten kommen? Ist evtl. eine Rsync über Remote Zugriff (SSH) Syncronisierung schneller als einme Rsync-Server basierte?

 

Als Hintergrund Info: Zu beiden NAS erreiche ich von einem ebenso am Switch mit 1GBE angeschlossenen Notebook eine Schreibrate von 58-59 MB/s und eine Leserate von 41-44 MB/s. Gemessen mit NAS Tester v1.7 mit 400MB Test-Dateien. Ich denke diese sind in zu erwartender Höhe, oder? Allerdings bricht die Datenrate schon wenn ich auf nur 100MB Test-Dateien gehe auf 13-15MB/sein...

 

Ich möchte nur sicherstellen, das ich nicht die Arbeit mit dem neu Installieren der beiden Systems (mit allen dann noch benötigten nachfolgenden Schritten) mache, nur um hinterher Festzustellen, dass die Performanz aufgrund von rsync so schlecht ist - und der ganze Aufwand dann umsonst war...

 

Viele Grüße

Dirk

Nachricht 7 von 11
Highlighted
NETGEAR Moderator

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Dirk_,

 

was Sie vielleicht noch versuchen können ist, wenn Sie Antivirus aktiviert haben, dies einmal zu deaktivieren und schauen ob es hilft.

 

Mit freundlichen Grüßen,
Ioannis
NETGEAR Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 8 von 11
Highlighted
Aspirant

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Ioannis,

 

nachdem ich jetzt lange den Antivirus Button gesucht habe, ihn aber nicht gefunden habe, habe ich gegoogelt und das Folgende gefunden: https://community.netgear.com/t5/Using-your-ReadyNAS-in-Business/Anit-Virus-Missing-on-Nas-102-Firmw.... Ist Antivirus jetzt nicht komplett deaktiviert? Ich hatte es vorher auch nie aktiviert, weil es hiess es braucht auf den kleinen System, wie meine RNS102s, viel Rechenleistung...

 

Grüße

Dirk

 

PS: Der rsync des letzten Shares läuft jetzt (braucht mit der aktuellen Datenrate von 3MB/s aber ca. noch 100h...).
       Danach würde ich dann das System einmal neu aufsetzen... 

Nachricht 9 von 11
Highlighted
NETGEAR Moderator

Re: Anleitung Erkennung Performance Bottleneck

Hallo @Dirk_,

 

genau da das Antivirus verhältnismaßig viel Rechenleistung benötigt sollte es bevorzugt deaktiviert werden. Es könnte sein, dass die gewählte Einstellung nicht registriert wurde.

 

Wir würden es sehr zu schätzen wissen, wenn Sie sich dann nochmals rückmelden könnten Smiley (fröhlich)

 

Mit freundlichen Grüßen,
Ioannis
NETGEAR Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 10 von 11
Highlighted
Aspirant

Re: Anleitung Erkennung Performance Bottleneck

@IoannisDM : So, übers Wochenende habe ich auf beiden RN102 das OS re-installiert (6.10.3). Danach ist die Datenrate beim rdist von vorher ca 3MB/s auf jetzt 6MB/s gestiegen, in meinen Augen aber immer noch viel zu niedrig...
Um das noch zu beschleunigen, habe ich Folgendes versucht:

a) Auf meinem GbE-Switch, einem SMC GS8P Smart, an dem beide NAS und der PC hängen, ein Firmware Update vorgenommen (von Version 1.4 auf version 4.1 - hatte ich vorher noch nie gemacht)
b) dann im Switch für alle drei Ports Flow Control aktiviert und
c) ebenso im Switch Jumbo Frame Support aktiviert.

Bei den beiden NAS habe ich dann versucht Jumbo Frames freizuschalten und dazu die MTU auf 9000 zu stellen. Erfolgreich bei NAS1, bei NAS2 hängt sich das System, nachdem ich die MTU auf 9000 gestellt habe, immer auf. Auch ein ssh mit anschliessendem manuellen
# ifconfig eth0 mtu 9000
oder manuellem
# ip link set dev eth0 mtu 1400
führt jeweils dazu, dass sich das NAS verabschiedet und nur durch hartes Power aus und ein wieder ansprechen lässt (mit entsprechendem folgenden, langen Sync Prozess...). Dazu habe ich bislang keine Erklärung gefunden. Im Folgenden also alle Messungen mit NAS1 auf MTU 9000 und NAS2 auf MTU 1500 (auch wenn die Zahlen das andersrum vermuten lassen!).

Allerdings haben mir die begleitenden Messungen, immer durch geführt mit NASTester v1.7 und 400MB Dateien, nicht gerade ein sehr aufschlüssiges Feedback gegeben:

Erster Lauf nach frischem OS:
NAS1: W 25,88MB/s R 26.11MB/s
NAS2: W 47,40MB/s R 47,20MB/s (keine Ahnung woher diese Differenzen kommen, beide NAS waren mit neu aufgespieltem OS)

Zweiter Lauf nach 16h (selbe Einstellungen)
NAS1: W 26,38MB/s R 25.75MB/s
NAS2: W 44,84MB/s R 39,97MB/s (höhere Datenreate beim NAS 2 scheint sich zu bestätigen)

Nach Deaktivierung Jumbo Frames im NAS1:
NAS1: W 30,09MB/s R 33.09MB/s (heisst Jumboframe deaktivieren führt zu höherem Durchsatz???)

Nach Deaktivieren Flow Control im Switch:
NAS1: W 31,62MB/s R 33.35MB/s (keine wesentliche Auswirkung!)
NAS2: W 35,87MB/s R 35,33MB/s (hier Einbruch der Datenrate?)

Nach Deaktivieren von Unterstützung Jumbo Frames auch im Switch:
NAS1: W 33,03MB/s R 34.59MB/s (keine wesentliche Auswirkung!)
NAS2: W 31,39MB/s R 33,19MB/s (nochmal Einbruch der Datenrate beim Schreiben?)

Stehe jetzt da mit einer in meinen Augen nicht akzeptablen rdist-Datenrate, einem RN102, welches keine MTU Erhöhung auf 9000 ermöglicht, anfänglich sehr unterschiedlichen Datenraten der beiden NAS (trotz neu Aufspielung OS und exakt gleichen Platten (WD Red 4TB) und Messwerten, aus denen ich nicht schlauer werde...

Jeder Hinweis, der zu einer Verbesserung führt ist willkommen!
Dirk

Model: RN102|ReadyNAS 100 Series 2- Bay
Nachricht 11 von 11