Reply
Highlighted
Luminary

New Firmware Released RAX80 1.0.3.88

Bug Fixes:

  • Fixes the issue where the wireless transmit power does not match the percentage set by the “Transmit Power Control” setting, which is on the of Advanced-Wireless-Settings page of the router web interface.
  • Fixes minor bugs.
  • Fixes security bugs.

New Features and Enhancements:

  • Supports NETGEAR Armor.
  • Supports NETGEAR Circle parental control
  • Improves the device type and model detection.
  • Supports the DHCP option 60/61 protocol for Internet.
  • Supports OFDMA for 2.4 GHz and 5 GHz separately.

Firmware Update Instructions:

Download Link: http://www.downloads.netgear.com/files/GDC/RAX80/RAX80-V1.0.3.88_1.0.41.zip

To update your router’s firmware, follow the instructions in your router’s user manual. To view your router’s user manual, visit https://www.netgear.com/support/product/RAX80.aspx#docs.

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

My RAX80 will NOT upgrade to this.

Message 2 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88


@baileyj0611 wrote:

My RAX80 will NOT upgrade to this.


I'm afraid that "will NOT upgrade" doesn't help when trying to debug your problem.

 

What are you doing and what happens when you try?

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 3 of 55
Highlighted
Star

Re: New Firmware Released RAX80 1.0.3.88

I've been lucky as my RAX80 has been flawless behind an CM1000 modem.  Now since the .88 update, I've has constant internet drops.  I guess it's my turn now.  Doing a factory reset is the only way to get the internet back but it doesn't last long.     

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 4 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

When the router tries to perform self update, it states no new firmwares available.

 

When I try to manually do it, it says the FW file is wrong and will not update.

 

This router is garbage. 

Message 5 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

Also using it as a network storage host is basically imposisble.

 

Multiple drive sizes with different fomratting, all lose connection and the router reboots.

 

 

Message 6 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

Update done, every thing works, include my NAS.

Message 7 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

did you have to use TFTP? I'm going to give TFTP a go, since I can't do it any other way.

Message 8 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

no, I have downloaded the zip file, unzipped it and upgrade manually the router in his web page interface

Message 9 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88


@FredAloneForEve wrote:

no, I have downloaded the zip file, unzipped it and upgrade manually the router in his web page interface


Always the best strategy.

 

No flaky wifi to get in the way, no chance of a broken download.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 10 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88


@baileyj0611 wrote:

 

When I try to manually do it, it says the FW file is wrong and will not update.

 


This is usually a sign that someone is trying to apply firmware for a different device, that they have got a corrupt download file, or they are trying to upload the whole zipped download rather than the unpacked firmware bit.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 11 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

I am pushing only the chk file, redownloaded twice and tried.

 

guess i'll keep trying 

Message 12 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

I think the last firmware that worked with network storage was 1.0.1.64.  I had to downgrade to that version, and have not moved off that firmware because it had been the most stable for me.

Message 13 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

Where can I find that download? Thanks.

Message 14 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

Message 15 of 55
Highlighted
Luminary

Re: New Firmware Released RAX80 1.0.3.88

After this firmware update it is important do a factory reset. I was still getting LAN disconnects after I upgraded from 1.0.2.76. Aftter factory reset LAN / WAN has not reset after 30 hours. I am checking the LAN/WAN uptime under statistics. 

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 16 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

Hi everyone,

I have upgraded with .88 firmware.

If i check the WPA2+WPA3 box in the wifi settings page, I can't check the smart wifi box in the same time.

 

If I want the smart wifi feature, I have to stay in WPA2 security mode.

 

Is it the same for you?

Message 17 of 55
Highlighted
Tutor

Re: New Firmware Released RAX80 1.0.3.88

Good step in the right direction! This update did bring some performance gains to my router, that is always welcome. The biggest thing i appreciate is the additioins to the UI. We need more control over this awesome device! Please keep working on this devices firmware, it has all the power now we just need the control! I upgraded from the R7000 and that thing had more granular control than this router. Give this router more attention regarding the UI (web UI), people who will be/are buying this device are power users for the most part and giving those users what they want and need will make this a much more attractive product. 

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 18 of 55
Highlighted
Guide

Re: New Firmware Released RAX80 1.0.3.88

Just want to chime in with my experience using 1.0.3.88 for the last few days. From the client side it has been great, my wifi 6 units have been working flawlessy with WPA3 enabled. in short, no dicernable disconnects etc to report from the end user point of view.

 

When digging a little deeper the RAX80 still present some peculiarities, though. First a little about my setup: Internet -> ISP provided cable modem/router in bridge mode -> RAX80 (with AX, OFDMA & MU-MIMO all enabled) -> Netgear MS510TX switch connected to all wired clients. For further context; I live in an appartment building with around a dosen networks "fighting for supremacy", but using wifi 6 and a channel without much congestion wifi has been stable.

 

Now the peculiarities:

  • The "Show statistics" page on the advanced home screen still show intermittent WAN drops/reconnects (about once every 24 hours). Strangely I have yet to find corresponding log entries in the ISP modem or the RAX80 log. 
  • The connected LAN port also seems to reconnect/drop from time to time, albeit less frequent than the WAN port. No log entries for these drops show up in the router log, nor the switch log either.
  • Trying to disable the "inlude known DoS attacks and Port scans" log category results in a ERR_CONNECTION_RESET page when clicking apply.
  • The "Attached devices" page is clearly an improvement, yet I still find it somewhat unpredictable. Devices seem to linger in this list long after they have been turned off/disconnected, even after pressing refresh several times. Also, depending on how you view the list (router web view or Nighthawk app), the number of devices may also differ.

I have no idea if the log or the statistics view are correct, but there are clearly some discrepancies between them. In general this firmware release has been nice, just some oddities evident for the network tinkerers among us.

Message 19 of 55
Highlighted
Guide

Re: New Firmware Released RAX80 1.0.3.88

I forgot to mention that I also did a factory reset after upgrading.

Message 20 of 55
Highlighted

Re: New Firmware Released RAX80 1.0.3.88

When was WPA3 added to the RAX80?

Message 21 of 55
Highlighted
Guide

Re: New Firmware Released RAX80 1.0.3.88

In the 1.0.3.88 release, even though it isn't listed in the release notes.

Message 22 of 55
Highlighted
Luminary

Re: New Firmware Released RAX80 1.0.3.88

WAN / LAN disconnections / reconnections are still occuring but not occuring as often like on previous firmware.

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 23 of 55
Highlighted
Star

Re: New Firmware Released RAX80 1.0.3.88

I have continuous internet drops on.88 and have tried uninstalling an reinstalling it 3 times now with factory reset.  The previous firmware to .88 is rock solid for me.  One thing I noticed is if you go into the router setup and select advanced, then you page down to the box that shows the 5g status on the right.  I use channel 44 but in this box it shows smart connect enabled which has worked for me but then under that is channel and it has a string of strange charters which don't make any sense.  Under that is mode it shows 1200 not 4800.  I have 4800 set for 5g in wirless settings.  Something is corrupt there.  This is why my phone keeps asking for the ssid password as I roam through the house.  Internet won't stay connected.

Message 24 of 55
Highlighted
Apprentice
Apprentice

Re: New Firmware Released RAX80 1.0.3.88


@M5Pilot wrote:

I have continuous internet drops on.88 and have tried uninstalling an reinstalling it 3 times now with factory reset.  The previous firmware to .88 is rock solid for me.  One thing I noticed is if you go into the router setup and select advanced, then you page down to the box that shows the 5g status on the right.  I use channel 44 but in this box it shows smart connect enabled which has worked for me but then under that is channel and it has a string of strange charters which don't make any sense.  Under that is mode it shows 1200 not 4800.  I have 4800 set for 5g in wirless settings.  Something is corrupt there.  This is why my phone keeps asking for the ssid password as I roam through the house.  Internet won't stay connected.

 


I have seen similar issue when I set 5GHz to WPA3 only... it started causing iPhone 11 to disconnect randomly often or say the password was invalid. Only fix so far was to set it to WPA2 or WPA2 & WPA3 option.


Also router randomly reset itself completely today so spent over an hour reflash firmware and restore settings... this thing has been nothing but trouble. Between Netgear's BS and Comcast completely fed up and tired of spending money on stuff that doesn't work and companies don't seem to care.

 

I looked into other options such as Amplifi Alien but it has its own issues and no manual channel selection or DFS support so looks like will have to continue to tough it out. I don't want to go back to non AX router, I don't want to use Comcast router due to lack of config options, and I don't want to spend anymore money ... very frustrating 

Message 25 of 55
Top Contributors
Discussion stats
Announcements