Orbi WiFi 7 RBE973
Reply

Nighthawk R9000, Alexa remote access settings

WGJOC
Tutor

Nighthawk R9000, Alexa remote access settings

I've just installed a band-new Nighthawk R9000.  In doing so I thought I'd install the PLEX server and instead of using my Seagate USB drive full of media on my Raspberry Pi I'd plug the Seagate into the R9000 USB port.  I can get video to play nicely through the Plex app on my computers, mobile phones, and Bravia TV so it must be more or less hooked up OK.  However I am having problems with Alexa/Echo.  It used to hook up nicely when the Pi was the server, but although I have changed the server to the new server name it won't now play the music from the Seagate disk. 

 

The R9000 (into which the media drive is now connected) is plugged directly into my ISP (BT) router which still goes out to the internet (with wireless disabled), but everything else including the USB is plugged into the R9000 which when it set up appeared to take on the existing BT router ID and password.  (I do not use the new details now that came with the R9000).

 

It looks like Plex remote access could be the issue, the Plex app is telling me:

Not available outside your network

Your server is signed in to Plex, but is not reachable from outside your network. Learn moreTip: It looks like your server may be connected to the internet through multiple routers or other network devices. Try connecting it directly to your primary device, or visit our support site for more information about troubleshooting this "Double-NAT" scenario. Learn more

Without full remote access the Echo system can't 'see' the media to play.  I've queried the 'Double-Nat' issue, but that appears to require looking to see what IP addresses the router has assigned, but the R9000 is set to 'get these dynamically from the ISP' so I can't see what it has been assigned.

 

Some help or pointers to get Alexa/Echo to hook up to the music would be great - at the moment I'm getting "Hu-oh, something went wrong I've alerted the Plex team" from the Echo device.  Many thanks 

 

 

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 1 of 3

Accepted Solutions
schumaku
Guru

Re: Nighthawk R9000, Alexa remote access settings

Your RasPi was operating on the first LAN behind the provider NAT router - thus  simple port fowarding does the job, probably it did it automatically by UPnP.

 

What's the point of adding another router doing NAT again? Your choice ... Check this:

 

https://support.plex.tv/articles/200931138-troubleshooting-remote-access/

 

Add a DHCP reservation for the R9000 WAN/Internet MAC address (connected to the provider NAT router LAN), then add aport forwarding for port 32400/TCP on the provider router to the R9000 "WAN" IP.

View solution in original post

Message 2 of 3

All Replies
schumaku
Guru

Re: Nighthawk R9000, Alexa remote access settings

Your RasPi was operating on the first LAN behind the provider NAT router - thus  simple port fowarding does the job, probably it did it automatically by UPnP.

 

What's the point of adding another router doing NAT again? Your choice ... Check this:

 

https://support.plex.tv/articles/200931138-troubleshooting-remote-access/

 

Add a DHCP reservation for the R9000 WAN/Internet MAC address (connected to the provider NAT router LAN), then add aport forwarding for port 32400/TCP on the provider router to the R9000 "WAN" IP.

Message 2 of 3
WGJOC
Tutor

Re: Nighthawk R9000, Alexa remote access settings

Hello schumaku, I think a solution as you describe is probably worth trying - I like the sound of fixing the ports - it just sounds the correct and elegant thing to do.  Unfortunately I am not into tinkering with these things, but I know someone who is up to the job who is visiting in a couple of weeks and I shall show them what you have written and get them to sort it out for me (I will report back then).  In any event for the moment I appear to have implemented that seems to be working, but I don't know why.  I plugged in the Seagate drive into one of the USB ports on the R9000, then two nights ago I power cycled the R9000 with the drive attached.  At the time it did not appear to have changed things and it still didn't work.  However, knowing that sometimes these things get their underwear in a bit of knot I left it all cogitating and went to work.  At lunchtime I tried my Android phone and lo and behold there it was and when I got home Alexa had no problems hooking up to the music on the drive, which was the original problem.  Happy?  Yes!  Baffled?  Certainly!

 

For the moment I shall leave it apparently working, but in case a 'dynamic change' of port in the future upsets it I am keen to apply your solution, so many thanks

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1806 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi 770 Series