Orbi WiFi 7 RBE973
Reply

Re: R8000 NAT/port forwarding issue

Bobby121418
Aspirant

R8000 NAT/port forwarding issue

Hi,
I just got the R8000 and it sits between my service provider modem/router and my Synology NAS.
I have configured the R8000 to be on a different subnet (192.168.1.1) to my broadband provider (EE Smarthub) (192.168.0.1). The EE Smarthub no longer has DHCP enabled nor am I using its WiFi. I have also configured port forwardings on both routers to get remote access to my Synology.
The problem: I can access my Synology NAS from external network using the DDNS configured domain, but cannot do the same on the internal LAN. I can however access it locally by using its local network IP address (192.168.1.X).

Can anyone please help?
Many thanks
Bobby
Message 1 of 10
FURRYe38
Guru

Re: R8000 NAT/port forwarding issue

This would be a double NAT condition which isn't recommended.

https://kb.netgear.com/30186/What-is-Double-NAT
https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT
Couple of options,
1. Configure the modem for transparent bridge or modem only mode. Then use the NG router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the NG router gets from the modem.
3. Or disable all wifi radios on the modem and connect the NG router to the modem, LAN to LAN configure AP mode on the NG router.
https://kb.netgear.com/24104/How-do-I-change-my-Nighthawk-router-to-AP-mode-after-I-ve-already-run-s...

 

Try option #1 first, if not, #2...

Message 2 of 10
Bobby121418
Aspirant

Re: R8000 NAT/port forwarding issue

Hi,
Thank you very much for your suggestions. I have in fact configured as option 2 as you suggested because the modem/router does not allow bridge mode. I am still however having the issue I mentioned.
Thanks
Message 3 of 10
FURRYe38
Guru

Re: R8000 NAT/port forwarding issue

Depending upon now well the DMZ or IP pass thru is on the ISP Modem, you may still encounter the double NAT issue. 

You may need to put the R8000 in to AP mode and let the ISP modem handle the NAT. 

Message 4 of 10
Bobby121418
Aspirant

Re: R8000 NAT/port forwarding issue

Hi,

Thanks for your help so far.

So I have done a tracert (via CMD) and its funny because I can get route traces for sites, such as the BBC or CNN, but cannot get my NAS domain name address resolved. It's as if DNS is not recognising my domain name. However, if I try to access my domain name from outside my LAN, I can get through.

Any thoughts? Is it a certificate problem ever since I added the Netgear router in?

Thanks

 

Message 5 of 10
FURRYe38
Guru

Re: R8000 NAT/port forwarding issue

If your trying to get responced back thru the router, not sure if this model supports loop back which is sometimes needed when resolving from the LAN to WAN back to LAN side. 

 

If the R series router is in the ISP modems DMZ, this should help alleviate some of the double NAT issues however I've see some ISP modems not do DMZ or IP passthru correctly. 

You might try the NAS connected to the ISP modem and see if it works there with out the R series router online...

Message 6 of 10
Bobby121418
Aspirant

Re: R8000 NAT/port forwarding issue

Hi,
Thanks for your suggestions.
So, I had the configuration initially where my NAS was connected directly to the ISP router and all was fine.
I tried your solution by putting my ISP router in DMZ mode to the NG R router. The problem is twofold:
1. The NAS now connected to NG R however, I can only connect to the NAS via 192.xxx.xxx.xxx IP while at home (on WiFi) and the DDMS domain does not work. The domain address only works if I am on an external network i.e on mobile.
2. I get video streamed from the NAS onto TV on the same Lan with a lot more buffering than when the NAS was connected directly to the ISP router and no NG router in the middle.

Thanks
PS. My ISP router doesn't do bridge so the option as you suggested was DMZ and no firewall or DHCP.
Message 7 of 10
FURRYe38
Guru

Re: R8000 NAT/port forwarding issue

Well you can set everything up ont the ISP router and turn OFF its wifi radios and set the R8000 up for AP mode. Might be best option for you. 

Message 8 of 10
Bobby121418
Aspirant

Re: R8000 NAT/port forwarding issue

Yes, I forgot to mention. I did try the AP mode, spent a lot of time on it but to be honest I didn't really see much benefit. In fact the domain DDNS that was accessible from an external network was no longer working. What is the benefit of AP mode anyway? Thanks
Message 9 of 10
FURRYe38
Guru

Re: R8000 NAT/port forwarding issue

No routing on the 8000 router and letting the ISP upstream router handle all the router management. 

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 1249 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 7