Orbi WiFi 7 RBE973
Reply

WNR2020v3 can't get IP address from R6700v3

KorporalKrump
Initiate

WNR2020v3 can't get IP address from R6700v3

I have been trying to set up my home network with a 2nd router that I want to use as a guest network WiFi on a separate vlan.  I had this mostly working in the following configuration:

 

Ubee Cable Modem/Router was set up for LAN addresses on 192.168.10.x .  I then connected my Nighthawk R6700 to the Ubee ethernet port as WAN 192.168.10.2 and LAN 192.168.0.x, and then finally I had The WNR2020 connected to the Ubee ethernet port as WAN 192.168.0.3 and LAN 192.168.4.x.  This for the most part worked but I had some double NAT issues that I was trying to resolve on the Nighthawk for my Plex Server.

 

So I switched my Ubee into Bridge mode and was going to skip the router at the Ubee level.  I figured I don't really care too much about double NAT issues on the guest vlan and this would resolve the double NAT on the network I typically use. The new configuration looks like this:

 

Ubee Cable Modem bridged connected to R6700(no longer a router).  The R6700 gets the public IP address and has DHCP on 192.168.0.x(range 100-254) I have a switch connected to the R6700 and then have th WNR2020 WAN port connected to the switch.  No matter what I do, I cannot get the WNR2020 to get an IP address from the R6700.  I've tried assigning it a static IP address and tried using DHCP as well.   I use the Advanced Home to look at the Internet configuration, and it's always 0.0.0.0.  I've tried pinging the gateway(192.168.0.1) but nothing.  Other devices plugged into the switch obtain an IP address no problem, and the same goes for DHCP from the R6700.  I've tried switching ports from the WNR2020 to the switch to a known good port thinking maybe I had a bad port but still got the same result   I even tried connecting an old ASUS router in the same configuration instead of the WNR2020 but that did the same thing and never received an IP address.

 

Any thoughts on why this isn't happening?  I'm going to try tonight to plug the WNR2020 directly into an ethernet port on the R6700 instead of going through the switch, but don't think that will really do anything.   I'm at a loss on this one and thining it is something with the R6700 that won't allow another router to get an IP address from it, but that's just my WAG.

 

Thanks.

Model: R6700|Nighthawk AC1750 Smart WiFi Router
Message 1 of 2

Accepted Solutions
KorporalKrump
Initiate

Re: WNR2020v3 can't get IP address from R6700v3

Just in case anyone comes across this in the future, the issue was the unmanaged switch.  I hooked up the WNR2020 directly to one of the ethernet ports on the R6700 and was able to resolve my issue.

View solution in original post

Message 2 of 2

All Replies
KorporalKrump
Initiate

Re: WNR2020v3 can't get IP address from R6700v3

Just in case anyone comes across this in the future, the issue was the unmanaged switch.  I hooked up the WNR2020 directly to one of the ethernet ports on the R6700 and was able to resolve my issue.

Message 2 of 2
Discussion stats
  • 1 reply
  • 664 views
  • 1 kudo
  • 1 in conversation
Announcements

Orbi WiFi 7