×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Nighthawk Mesh WiFi

Welcome to the Nighthawk Mesh Community


Advanced Whole Home WiFi Click to Buy Nighthawk Mesh WiFi 6
Reply

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Bradster
Tutor

Devices on mk62[mr60 and ms60] become invisible to each other

I have two google homes, a chromecast, two phones, and a desktop connected to my network. The desktop is the only one wired. On occasion, the LAN seems to be split into two networks for my devices because they will stay connected to the internet, but half of the devices aren't able to communicate to the other devices. For example, phone 1 could communicate to google home 1 and the chromecast, while phone 2 could only communicate to google home 2. The nighthawk app still shows all of the devices as connected (although it never shows my phone as a device) but pinging the other devices from my phone returned the error "Destination Unreachable". And this issue will happen 1-3 times a day for an hour or several hours.

Message 1 of 27
Christian_R
NETGEAR Employee Retired

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Hello Bradster,

 

Thanks for reaching out. I'd like for our support team to reach out for further assistance. Please send me a message with your contact info and serial number. 


Thanks,
Christian 

Message 2 of 27
aadiit
Initiate

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Came here searching if I was the only one with this issue. I have 3 Chromecast and 2 phones (Android and iPhone). Sometimes one of the Chromecast won't connect to wifi at all. And if connected I am unable to cast anything. The issue is random, it can be any Chromecast and any phone. Earlier I had ISP provided router which ran flawless except that it didn't reach with enough strength in some rooms. The mesh wifi 6 is having good strength but this Chromecast issue is painful
Message 3 of 27
cdelat01
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

i have the same issue. the problem is the satellite. if you turn off the satellite everything works fine. the sad thing is it cuts off my yard. i have a case open but no fix so far.
Message 4 of 27
aadiit
Initiate

Re: Devices on mk62[mr60 and ms60] become invisible to each other

I just gave up and ended returning the system. What's the point of mesh system if I have to keep satellites disconnected
Message 5 of 27
cdelat01
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

they sent me new satellite and do far that one is working fine. what ever was wrong with mine had to be hardware and would also explain why so few folks have posted on this issue.
Message 6 of 27
MasterCh
Aspirant

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Same issue with two MK63 (mine and a friend kits). Chromecast and Google Home speakers became unavailable for casting.

Each Google Home can talk with their respective Chromecast, the one right on the same room.
Message 7 of 27
shaun_s
Star

Re: Devices on mk62[mr60 and ms60] become invisible to each other

I've been having similar problems. I've had the router for a few days now. At first I thought the problem was random then I did further testing. I'm quite sure the problem is related to the 5GHz wifi on the SATELLITES.

 

I have the MK63 (MR60 router and two MS60 satellites) with each node placed in SEPERATE rooms. I have 3 media devices (Google Home speaker, Google Home Mini speaker and Google Chromecast) and a few phones. The Chromecast is connected to the router, the Home to satellite 1 and the Mini to satellite 2. All devices are configured properly and connected to the internet. I have the latest firmware (V1.0.6.102) on the router and satellites.

 

The good news: No matter which node my phone is connected to, I can cast to a device connected to the router (Chromecast in my case). Also, if my phone is connected to the router, I can cast to all devices in the house. If my phone is connected to a satellite then I can cast to a device on the OTHER satellite (the speaker in the other room in my case), as well as to the device connected to the router. All is fine up to this point.

 

The problem start when my phone AND media device are connected to the SAME satellite. So when I'm next to a speaker I CAN'T cast to that speaker. Furthermore, the problem only happens when the media device is connected to the 5GHz band. (When the speaker uses the 2.4GHz band, the problem goes away.)

 

So does anyone out there have a solution?

 

Hey Netgear, Has anyone looked into the problem? It's been a while since the initial post. Is a new firmware with a fix available soon?

Message 8 of 27
Bradster
Tutor

Re: Devices on mk62[mr60 and ms60] become invisible to each other

I had reached out to the support team and they were unable to help me without me buying an extended warranty which I refused to purchase because its terrible for a consumer router at that price using new standards to come with such a short warranty. They then directed me to make a post here. I was never able to get it to work so I replaced it.
Message 9 of 27
shaun_s
Star

Re: Devices on mk62[mr60 and ms60] become invisible to each other


@Bradster wrote:
I had reached out to the support team and they were unable to help me without me buying an extended warranty which I refused to purchase because its terrible for a consumer router at that price using new standards to come with such a short warranty. They then directed me to make a post here. I was never able to get it to work so I replaced it.

Bradster,  Thanks for your reply.

 

I feel they've rush putting the product to the market without testing it properly.  I've seen other people in the forum having similar problems but it seems Netgear hasn't really responded.  I will try to contact support while I still have warranty.

Message 10 of 27
shaun_s
Star

Re: Devices on mk62[mr60 and ms60] become invisible to each other


@shaun_s wrote:

I've been having similar problems. I've had the router for a few days now. At first I thought the problem was random then I did further testing. I'm quite sure the problem is related to the 5GHz wifi on the SATELLITES.

 

I have the MK63 (MR60 router and two MS60 satellites) with each node placed in SEPERATE rooms. I have 3 media devices (Google Home speaker, Google Home Mini speaker and Google Chromecast) and a few phones. The Chromecast is connected to the router, the Home to satellite 1 and the Mini to satellite 2. All devices are configured properly and connected to the internet. I have the latest firmware (V1.0.6.102) on the router and satellites.

 

The good news: No matter which node my phone is connected to, I can cast to a device connected to the router (Chromecast in my case). Also, if my phone is connected to the router, I can cast to all devices in the house. If my phone is connected to a satellite then I can cast to a device on the OTHER satellite (the speaker in the other room in my case), as well as to the device connected to the router. All is fine up to this point.

 

The problem start when my phone AND media device are connected to the SAME satellite. So when I'm next to a speaker I CAN'T cast to that speaker. Furthermore, the problem only happens when the media device is connected to the 5GHz band. (When the speaker uses the 2.4GHz band, the problem goes away.)

 

So does anyone out there have a solution?

 

Hey Netgear, Has anyone looked into the problem? It's been a while since the initial post. Is a new firmware with a fix available soon?


EDIT:  I did some more testing.  The problem also happens on the 2.4GHz band.

 

So the problem happens when BOTH the media device and phone are connected to the SAME satellite on the SAME wifi band.

(It was difficult to test since the media devices don't allow selecting the band to connect, but I have an older phone which does allows me to choose the band to connect so it made it slightly easier to test.)

Message 11 of 27
AlbanyMatt
Tutor

Re: Devices on mk62[mr60 and ms60] become invisible to each other


@shaun_s wrote:


EDIT:  I did some more testing.  The problem also happens on the 2.4GHz band.

 

So the problem happens when BOTH the media device and phone are connected to the SAME satellite on the SAME wifi band.

(It was difficult to test since the media devices don't allow selecting the band to connect, but I have an older phone which does allows me to choose the band to connect so it made it slightly easier to test.)

 


I'm having the exact same problem with MR60 with two MS60 satalites. On another post, the workaround was to bring my old router back in and turn off the wifi on it. Then flip the router on the MR60 off so that it just became a Wireless AP system. As soon as I got that setup, everything worked across all satalites. 

 

Hope netgear fixed this in their next update. 

Message 12 of 27
shaun_s
Star

Re: Devices on mk62[mr60 and ms60] become invisible to each other


@AlbanyMatt wrote:

@shaun_s wrote:


EDIT:  I did some more testing.  The problem also happens on the 2.4GHz band.

 

So the problem happens when BOTH the media device and phone are connected to the SAME satellite on the SAME wifi band.

(It was difficult to test since the media devices don't allow selecting the band to connect, but I have an older phone which does allows me to choose the band to connect so it made it slightly easier to test.)

 


I'm having the exact same problem with MR60 with two MS60 satalites. On another post, the workaround was to bring my old router back in and turn off the wifi on it. Then flip the router on the MR60 off so that it just became a Wireless AP system. As soon as I got that setup, everything worked across all satalites. 

 

Hope netgear fixed this in their next update. 


Hi AlbanyMatt, Thanks for your suggestion.


Unfortunately, using the MR60/MS60 as a wireless AP was the setup I used at the very beginning. I thought it was the old router begin incompatible with MR60, so I reconfigured to use MR60 as the main router but the problem persisted.

Message 13 of 27
cdelat01
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

if you call support have them reference case #43114555. Hopefully they will provide you the fix for the issue. 

 

Message 14 of 27
cdelat01
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Contact support and reference case number:43114555. Hopefully they will provide you the fix.

Message 15 of 27
MarkH123456
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

What @shaun_s describes is EXACTLY my problem as well.

 

The Chromecasts can only be discovered by devices connected to either a different station or a different band. 

 

I have tried:

as sugegsted by Netgear support:

 - disable AX

 - adjust 2.4Ghz: channel 11 and 5Ghz: channel 44

 - MTU size: 1492 

 

 - enable RIP both directions (https://community.netgear.com/t5/Nighthawk-Routers-with-WiFi-6-AX/Chromecast-and-Mesh-Routing-issues...)

 

None of the above fixes the problem. Netgear support suggest contacting Google.

Message 16 of 27
MarkH123456
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Hi everyone,

 

I may have a solution. After trying various settings and spending an hour chatting to Netgear support, I found a thread where someone noticed the error after an upgrade. So I performed a downgrade to the version prior to theirs, and lo! it seems to have fixed the Chromecast problem. I haven't read through the release notes, so I am not encouraging people to open up potential security holes, but if you want Chromecast to work, this is what you can try. Also, I only just performed the downgrade and test, so can't confirm 100%, and will check back in after a week with more findings.

 

This process takes about 15-30 minutes and will take the router offline several times, so do this when its least disruptive to your smart home / office / fellow residents. 

 

To manually update the firmware:

  1. Go to https://kb.netgear.com/000061928/MR60-MS60-Firmware-Version-1-0-4-96 and download both files. Unzip these somewhere you can find them (I left them in the downloads folder).
  2. Make sure that your router is connected to your router via ethernet cable. Make sure your laptop is fully charged or connected to power. Do not use wireless connection - This process is only valid for a computer that is connected wired directly to the router via ethernet cable
  3. Turn off the wifi on the computer (only use the ethernet cable for communicating with the modem).
  4. Open a web browser and enter www.routerlogin.net or 192.168.1.1
    A login page displays.
  5. Enter the extender admin user name and password. (If you have changed these, then they will be the changed ones, otherwise it is the default admin/password)
    The Status page displays.
  6. Once your logged in go to Advanced > Administration > Router Update > Manual Update
  7. Uncheck the option 'Router Auto Firmware Update'. Click on Apply (this will take a few minutes and take the router offline)
    You will need to do the downgrade for the base station (MR) and each satellite (MS). 
  8. Click the Browse button, then locate and select the firmware file that ends in .img or .chk starting with MR.
  9. Click the Upload button. There will be a big warning message that this version is older that your current version. Press the accept / OK / proceed anyway button. 
  10. The firmware update starts and the router restarts. The firmware update process takes about two minutes.
    Warning: After you click the Upload button, DO NOT try to go online, turn off the extender, shut down the computer, or do anything else to the extender until it finishes restarting (interrupting the update process may render your device into an unusable brick). When the router finishes, you will need to log-in to the router settings page again.
  11. For each satellinte: 
    1. Click on the IP address of the satellite in the list below the Upload button. A new window/tab should open, enter the same router password as before.
    2. Browse > find the file that ends in .img or .chk starting with MS.
    3. Upload. Same warnings as above, be patient, get a cup of coffee or tea.

 

Once all the satellites are downgraded, test the devices on the network. All of mine reconnected automatically, and the Chromecasts were discoverable and more importantly usable, whether the mobile was connected to the same or a different station. You can unplug and turn the wireless connection back on your computer.

 

I hope all this helps. 🙂

Message 17 of 27
cdelat01
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Call support have them reference case #43114555. Hopefully they will provide you the fix for the issue.
Message 18 of 27
MarkH123456
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Hi @cdelat01 , can you share a bit about what #43114555 is about? I sent this to Netgear support but they closed the case. When I opened a new case and again mentioned your ticket number, they gave me instructions to do a factory reset. ???

Message 19 of 27
SuperMario28
Aspirant

Re: Devices on mk62[mr60 and ms60] become invisible to each other

I am having the same problem as well. I have a wireless printer along with Google home/chromecast devices that are invisible to my phones and each other when connected to the satellites but everything works when my phone is connected to the main router. My parents have the same issue as well. Did the downgrade in firmware end up working?
Message 20 of 27
MarkH123456
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Not entirely. 

 

At first, things seemed to work, then only the Android devices would be able to stream to the Chromecast, but after a day or so they stopped working as well.

 

I did the factory reset (hold a pin in the base station's reset hole for 30 seconds), which included an upgrade to v1.0.6.110 of the firmware. EDIT: to save yourself a lot of pain, write down the SSID and password to your current network before doing the factory reset, as it will revert to whatever is written on the base of the MR. After the reset you can change the settings back to your current values and all your devices should reconnect automatically.

 

First 24 hours, everything worked. Then at some point between 24-48 hours, things reverted to not working. A reboot of the base station (via 192.168.1.1) seemed to have enabled things to work again, but that was 8 hours ago, so still monitoring. It's quite frustrating.

 

A point to note: the 2.4ghz band is set to "auto" channel by default. Older equipment can only handle channels 1-11, so you might need to manually set it to either 1, 6, or 11 to make things work. Also turn off AX, unless you have only wifi-6 enabled devices. And check the security protocols that each device is capable of using. If you have a very old printer or PC, then you might need ot set a lower security spec. I have a guest network on with WPA1 for this reason, while the main network is WPA2. Be aware that devices on the two networks won't be able to see each other.

 

Make sure to open a support ticket in the first 3 months after purchase, otherwise they'll charge you for product support.

Message 21 of 27
Intel1234
Guide

Re: Devices on mk62[mr60 and ms60] become invisible to each other

Worst router I have ever used.

Message 22 of 27
steelman5
Initiate

Re: Devices on mk62[mr60 and ms60] become invisible to each other

I was having this same issue as well - tried to get help from support and had 2 cases closed on me automatically while level 2 support was supposed to get back to me. Referenced the case earlier in this thread about a fix and was told to downgrade my firmware but nothing seemed to work. I returned this router system to the retailer where I purchased it and switched to a different mesh system and everything just works now. No more headache, no more frustration and no more dealing with NETGEAR support! 

 

If you are having this issue - my suggestion - buy a different router. Hopefully they fix this issue in the future, but I am not going to wait around for them to fix it. 

Message 23 of 27
MasterCh
Aspirant

Re: Devices on mk62[mr60 and ms60] become invisible to each other

What brand/model did you end using?
Message 24 of 27
MasterCh
Aspirant

Re: Devices on mk62[mr60 and ms60] become invisible to each other

What for Christian. Nothing seams to work in this issue.
Message 25 of 27
Top Contributors
Discussion stats
  • 26 replies
  • 7235 views
  • 19 kudos
  • 11 in conversation
Announcements

Orbi WiFi 7