Reply

Another gmail alert question

twink
Aspirant

Another gmail alert question

Ever since I installed the latest firmware my alert settings that are there to send me alert messages to my gmail address have stopped working.

 

I'm currently trying the following:

 

Email Account Provider: Custom (can't seem to be able to change this)

User: my.email.address@gmail.com

Password: my password

SMTP server: smtp.googlemail.com

SMTP port: 465

From: my.email.address@gmail.com

Use TLS: yes

 

I have tried with SMTP server smtp.gmail.com, with SMTP ports 25 and 587 and without the TLS but I keep getting an error message whenever I try to send a test message.

 

Has anyone else experienced this and have some hints for me?

Message 1 of 11

Accepted Solutions
StephenB
Guru

Re: Another gmail alert question

Have you configured your gmail security to allow "less secure apps".  It won't work if you don't.

View solution in original post

Message 10 of 11

All Replies
BrianL
NETGEAR Employee Retired

Re: Another gmail alert question

Hi twink,

 

What model of ReadyNAS unit are you using? Also tell us which Firmware is running or installed.

 

I look forward to your response.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

Message 2 of 11
twink
Aspirant

Re: Another gmail alert question

My model is ReadyNas 104 running firmware 6.4.0.

Message 3 of 11
BrianL
NETGEAR Employee Retired

Re: Another gmail alert question

Hi twink,

 

Try to disable and remove the existing gmail account that you have entered in the email alerts section in the admin page. Add it again by clicking the plus icon and hit the automatic button to fill out the rest of the smtp settings then try to send a test email to see if it works.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

Message 4 of 11
StephenB
Guru

Re: Another gmail alert question

I use smtp.gmail.com for the SMTP server, and port 587,

Message 5 of 11
twink
Aspirant

Re: Another gmail alert question

I still can't get this to work. Here's what I do, step by step. What am I doing wrong?

 

1. On the settings -> alert page, I click on the plus sign next to "Alert Contacts".

2. In the popup dialog that shows up, I type in my gmail address: myaddress@gmail.com

3. In the Email Options on the right, I type in my email (gmail) address in the User field and my gmail password in the Password field.

4. In the SMTP server field, I type in smtp.gmail.com.

5. In the SMTP port field, i type in 587.

6. In the From field I type in my email (gmail) address.

7. I leave TLS unchecked.

8. I click the "Send Test Message" button and I get the following error message: "Unable to send test message. Cannot send a test message. Check settings. Code: 5008010000 msmtp: the server does not support authentication msmtp: could not send mail (account default from /etc/msmtprc).

9. I change the "User" to "admin" and the "Password" to my admin password on my ReadyNAS and try again, but with the same result (as in point 8).

Message 6 of 11
StephenB
Guru

Re: Another gmail alert question

TLS needs to be checked.

 

User/Password is for your gmail account, not the NAS.

 

Also, you will need to configure your gmail account to allow "less secure apps" https://support.google.com/a/answer/6260879?hl=en

 

To clarify what this means:

 

The NAS needs your gmail user/password to send mail.  That means you have to trust the NAS with that credential.  There are newer methods (particularly OAUTH) that would give the NAS a token instead of your actual credentials.  That doesn't require trusting the NAS to guard your credentials.

 

So "less secure apps" doesn't actually mean the NAS is insecure.  Only that you have to trust it to maintain security.

Message 7 of 11
BrianL
NETGEAR Employee Retired

Re: Another gmail alert question

Hi twink,

 

Sorry to hear that. Hope you could you try what I suggested previously. 

 

Looking forward to your response.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

Message 8 of 11
twink
Aspirant

Re: Another gmail alert question

Hi BrianL.

 

I'm not 100% sure what you think I should do that's different from what I have already done, but here's what I did this time:

 

1. I started up the admin GUI and went to settings -> Alerts.

2. Once there, I had no email address registered. The minus sign was disabled. I clicked the plus sign.

3. In the "Add Alert Contact" dialog that popped up, I wrote down my gmail address and clicked Add.

4. I then clicked the "Automatic" button and the following things were added: "Email account provider: smtp.gmail.com:465", "User: <my gmail address>", "Password: eight dots" (which is much shorter than my gmail password), "SMTP Server: smtp.gmail.com", "SMTP Port: 465", "From: <my gmail address>", "Use TLS: checked".

5. When I clicked the "Send Test Message" I got the following error: "Cannot send a test message. Check settings. Code: 5008010000 msmtp: authentication method LOGIN needs a password msmtp: could not send mail (account default from /etc/msmtprc)"

6. I entered my gmail password in the Password text box and clicked "Send Test Message" again. I then got this error message: "Cannot send a test message. Check authentication settings. Code: 5008010001 Error from msmtp.

7. I copied my gmail password from my password managed and pasted it into the "Password" text box to make sure I didn't mistype it and tried again, but with the same result.

8. I clicked the "Apply" button in the bottom right and noticed a loading wheel appear next to "Alert Settings" (or whatever it says) on the left. Nothing happened in about 10 seconds, so I thought I would try to not use the automatic settings, so I clicked the "Automatic" button and noticed the advanced settings were still disabled. Then, all of a sudden, the settings page disappeared and I got a loading screen that said something like "Connecting to the ReadyNAS Admin Page..." or something like that. After about 30 seconds of loading, I got a big white screen with "NETGEAR ReadyNAS version 6.4.0" in the center. I clicked around but nothing happened. Then, after another 30 seconds I got the same loading screen again and after yet another 30 seconds, the big "NETGEAR ReadyNAS version 6.4.0" screen again. One minute later the main page of the admin GUI loaded. I clicked "Settings" and waited for it all to load. Then I got the "Connecting to the ReadyNAS Admin Page..." loading screen again, followed by the "NETGEAR ReadyNAS version 6.4.0" page. And then the "Connecting to ReadyNAS Admin Page..." again.

9. At this point, it was already midnight and I figured I would let this loop go on throughout the night and see what it looks like in the morning.

Message 9 of 11
StephenB
Guru

Re: Another gmail alert question

Have you configured your gmail security to allow "less secure apps".  It won't work if you don't.

View solution in original post

Message 10 of 11
twink
Aspirant

Re: Another gmail alert question

That was the fix.

Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 11932 views
  • 4 kudos
  • 3 in conversation
Announcements