Reply

New - XR450/XR500 Firmware Version 2.3.2.134 Released

FURRYe38
Guru

New - XR450/XR500 Firmware Version 2.3.2.134 Released

Enhancements: 04/12/2022

  • Remove Funjsq for PR SKU
  • Various security enhancements

Bug Fixes:

  • Fixes an issue where the name of an attached device cannot be changed in the device manager through the Nighthawk app.

Security Fixes:

  • Fixes security vulnerabilities.

For more information about security vulnerabilities, visit https://www.netgear.com/about/security/

 

XR450:

Download Link: 

https://www.netgear.com/support/product/XR450.aspx#download

 

XR500:

Download Link: 

https://www.netgear.com/support/product/XR500.aspx#download

 

Firmware Update Instructions:

To update your router’s firmware, follow the instructions in your router’s user manual. To view your router’s user manual, visit  https://www.netgear.com/support/product/XR500.aspx#docs

https://kb.netgear.com/23960/How-do-I-manually-update-the-firmware-on-my-NETGEAR-router

 

NOTE: It's recommended to factory reset and setup from scratch after applying this FW update. 

 

 

This article applies to:

Nighthawk Pro Gaming (1)

Let us know how it works for you...

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 1 of 59
domino138
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Upgraded firmware, factory reset via GUI, 30 second press of the reset button on the back just to make sure.  Reconfigured all settings - everything seems to be working fine.  These are the settings I have different to default:

 

  1. Ran the Wizard and added username and password for PPPoE (UK ISP)
  2. Configure Google DNS instead of using ISP's DNS
  3. Allowed the router to run its own speed test
  4. Enable QoS and reduce to give headroom for congestion control
  5. Ran DSL Reports speedtest and scoring A+ / A / A+ so pretty happy
  6. Disable:
    1. uPnP
    2. WIFI radios (I have separate WiFi access points)
    3. Media Server, USB and ReadyShare

 

I don't use the Geo-Filter or Hybrid VPN so cannot comment on those.

 

Will let you know if there are any issues.

Model: XR500|Nighthawk Pro Gaming Router
Message 2 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Pease don't use 30 second press of the reset button. Only 10 seconds is needed. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 3 of 59
blackshirt40
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

when i click the QoS option i am greeted with a device not found, also when i try to run the connection benchmark nothing happens

Model: XR500|Nighthawk Pro Gaming Router
Message 4 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Did you factory reset the router and setup from scratch after loading the FW? 

What browser are you using? 

Be sure to clear out browser caches before entering the routers web page. 


@blackshirt40 wrote:

when i click the QoS option i am greeted with a device not found, also when i try to run the connection benchmark nothing happens


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 5 of 59
blackshirt40
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

i tried the hard button reset on the back, held for ten seconds. it rebooted the router but saved info was still there, then i did the factory erase option(think that is what its called) and that did reset it. so long answer is yes. I have also tried both chrome and edge

Message 6 of 59
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

You may need to downgrade back to .130, factory reset, then upgrade to .134 and don't reset. That'll fix it for you.

Message 7 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

WIth v.130 applied, I applied v.134 over the top then used the ERASE fuction to factory reset the router. Used MS Edge to set up the router and walked thru the setup wizard. 

I recommend clearing out all browser caches prior to walking thru the setup wizard. 

 

The "Device not found" message appears on the QoS page:

DeviceNotFoundMessage.bmp

Wired speeds are to spec:

Over900MpbsSpeeds.bmp

Connection Test is working however the download doesn't reflect what external speed test app says:

ConnectionTest.bmp

 

Something I noticed this morning, I had used the top WiFi enable/disable button yesterday to turn OFF the wifi radios. Left them OFF over night. I looked over this morning and found the 5Ghz radio enabled LED on the front of the router this morning. I used the button to enable the radios, then agian to disable the radios, both LEDs turned OFF. I'll check this again later. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 8 of 59
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Thanks for the detail as always, the Device not found error is a weird one but it can be fixed by downgrading to .130, resetting, then upgrading again without resetting after.

 

Looks as though Connection Benchmark is reporting incorrectly, out of interest can you let me know if you get expected results running a speedtest here:

https://speed.measurementlab.net/

 

Let us know how you get on with the Wi-Fi.

Message 9 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Ok, speed test for that site linked in MS Edge:

MeasurementLabSpeedTestReultsMSEdge.png

Uplink isn't near to 50Mbps specs. 

 

Got home and WiFI LED is still OFF. I'll continue to check this tomorrow morning. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 10 of 59
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

We haven't made any changes in this version so Benchmark still needs to be improved, did you see full speeds on Benchmark on the previous version?
Message 11 of 59
domino138
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

I’ve not had a good experience with QOS on this version. Since the upgrade I’ve felt that even normal web browsing performance is sluggish. One of my children said that CS GO was unplayable. I play Factorio and I put in a manual QOS rule in for it (as on the previous version) but latency was noticeably worse (spikes up to 250 ticks).

You can see the actions I took to upgrade in my previous post. I went from v120 to v134. I’ve now downgraded to v130 without a factory reset and things seem to be working fine again.
Model: XR500|Nighthawk Pro Gaming Router
Message 12 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

v.130: Taken 20211105

ConnectionTest1withRBRDoubleNat.png

 

Also downgrading to v.130, factory reset, then update back to v.134 doesn't resolve the "Device Not Found" message seen in QOS. Still appears for me. Though only seen once after entering into QoS. 

 

Ran the Connection Test after downgrading to v.130, reset then back up to v.134:

ConnectionTest2AfterDownThenbackUP2v134.png

QoS disabled. A bit better results on the down. Still not near 900Mpbs.

 


@Netduma-Fraser wrote:
We haven't made any changes in this version so Benchmark still needs to be improved, did you see full speeds on Benchmark on the previous version?

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 13 of 59
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

@domino138 go back to using the ISP DNS, Google DNS maybe too slow for you, it would be better to be on the latest for the security updates.

@FURRYe38 You'll have to downgrade to a non 3.0 version, factory reset then upgrade so .114 or .120 for example. Okay so it's actually improved a little weirdly. As mentioned we haven't made any changes so bugs on the DumaOS side of things that were present on .130 are very likely to be on this version as well. Don't worry though, it's just a reporting issue, you're getting the speeds Ookla says.
Message 14 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

I see. OK. Well the message only appears once and doesn't seem to both anything. I'll leave the router at .v134 for now. I'll get this going live on a 2ndary network tomorrow and let it run over the weekend with WiFi enabled. WIll monitor. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 15 of 59
mathmath51
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Hi, Does this version include fixes related to the DHCP issue please ? 

No I'm not going to test it for the Netgear "QA" 😉

Model: XR500|Nighthawk Pro Gaming Router
Message 16 of 59
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

The change log does not mention it so it is very unlikely unfortunately
Message 17 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Currently running v.134 and not seeing any DHCP issue. I have left the DHCP server configuration at default.


@mathmath51 wrote:

Hi, Does this version include fixes related to the DHCP issue please ? 

No I'm not going to test it for the Netgear "QA" 😉


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 18 of 59
Panos_78
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Hi FURRY,

 

If update the new firmware and after factory reset restore from backup I have any issues?

With .130 firmware after factory reset I don’t have it any problems. Need to update the new firmware? Is important? Router working better with .134?

Model: XR500|Nighthawk Pro Gaming Router
Message 19 of 59
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

@Panos_78 it is not advised to upgrade, reset and then restore as you could bring issues back. It is more of a maintenance & security upgrade so it is recommended but depending on how you feel about that, not necessary. You're unlikely to have any performance improvements by upgrading.
Message 20 of 59
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

5Ghz speeds are good: 

5GhzOver900MpbsASUSGTAX11000Bridge.png

ASUS GT-AX11000 in wireless bridge mode.

 

iPhone 12 pro max is seeing to spec speeds as well for 5Ghz AC with 160Mhz enabled:

Screenshot 2022-04-18 at 5.30.03 PM.png

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 with Orbi RBKE963 (AP Mode), | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 21 of 59
domino138
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

As per the previous posts above I went from .120 --> .134 --> .130.  Gaming latency has been unacceptable on both .134 and .130 so I've downgraded to .120 again.  I'll wait until the next release to try again.

Model: XR500|Nighthawk Pro Gaming Router
Message 22 of 59
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

You mentioned previously that things were fine on  .130, how long did it take for you to start noticing that latency got worse? For example, after a couple of days uptime? If you rebooted the XR through the front-end did things get better temporarily?

Message 23 of 59
domino138
Luminary

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

Hi Liam - when I said .130 was fine I hadn't really given it enough time to see what was happening.  Can you tell me what the proper upgrade path is from .120 to .134.  I'd obviously like to be on the most secure version but perhaps I didn't follow the correct steps when upgrading?  A step by step list of actions would be good and I don't mind doing complete resets and configuring from scratch.

Model: XR500|Nighthawk Pro Gaming Router
Message 24 of 59
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.134 Released

There shouldn't be an upgrade path as such, however some users have had an error in QoS so until that's fixed I'd suggest the following to be safe:

  • Downgrade to the last 2.0 firmware (2.3.2.114)
  • Factory reset the XR500
  • Upgrade to the latest full release 3.0 firmware (2.3.2.134) without factory resetting

Let me know if you're still having issues after that.

Message 25 of 59
Discussion stats
Announcements

Orbi WiFi 6E