Orbi WiFi 7 RBE973
Reply

RN214 Shows All Volumes As Red

Bigmaca
Aspirant

RN214 Shows All Volumes As Red

Hi, 

 

My ReadyNAS 214 recently powered off and after turning it back on it now shows the three volumes that I have in the colour Red. The markers are green which makes me assume they are fine but I don't know why they are showing up as Red. 

 

Screenshot 2022-07-12 at 19.16.28.png

 

I've tried booting in Read-Only mode but this hasn't worked. I've also updated the firmware. I'm currently running: 

 

Firmware: 6.10.7


I've been running X-Raid and I really need to get some of the data off some of these drives at the very least. Any help would be really appreciated as I'm panicking a bit and don't know what to do. 


Can I get a SATA cable and connect these drives directly to a laptop if I can't access it through the NAS? I'm happy to provide logs and anything else that might be of use to help this. 

Model: RN21400|ReadyNAS 214 Series 4- Bay (Diskless)
Message 1 of 19

Accepted Solutions
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

This has now been resolved. 

 

After having no help with Netgear Customer service, @StephenB was able to offer fantastic assistance. I ended up needing to force a resit of the drives through a telnet terminal. There was then a need to delete chunk stream files that had been left over from Plex that where on the admin page. 

 

Thanks again StephenB. 

View solution in original post

Message 18 of 19

All Replies
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

My ReadyNAS 214 recently powered off and after turning it back on it now shows the three volumes that I have in the colour Red.

 Be careful on the vocabulary.  You have one data volume (currently inactive), and three disks.  The three disks are red because they are not part of an active data volume.

 

Was the shutdown graceful, or was there a sudden loss or removal of power?  I am thinking it might be the latter.  That can create an out of sync volume, due to cached writes that were lost when the power failed.

 

I'd start with Netgear support (support.netgear.com), and see if you can get paid support from them. 

Message 2 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

Hi StephenB, 

 

Thank you for the help here and sorry for the use of the wrong vocabulary. Still trying to get my head round it. I believe there was a sudden abrupt loss of power but I can't be sure. I'll look at using the support you mentioned. 

Message 3 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

Hi StephenB, 


Would a possible reinstall of the OS fix this issue? 


I'm also not sure on what level of support to purchase with Netgear, it's not very clear. 

Message 4 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

Would a possible reinstall of the OS fix this issue? 

 


No, that won't help at all.

 

There are a few possibilities -

  1. the RAID array might be too far out of sync to mount manually.  It can be "forcibly" assembled,
  2. the RAID array might be ok, but there might be some BTRFS file system corruption which is blocking the mount. 

If (2) the corruption might be repairable with normal BTRFS tools.  Or actual data recovery might be needed.

 

Based on what we know at this point, I think there's a good chance of avoiding full data recovery.

 

Message 5 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

Thank you Stephen. 


I've just created a case and am waiting for Netgear to get back to me. I've tried contacting premium support but they said I need to have a case number first. 

 

I'm worried they won't be able to offer support for the device. If that's the case do I have any other options to get my data off the drives? I'm assuming that doing a manually mount or BTRFS file corruption is something that I can sort myself. 

 

Really appreciate your help and guidance on this. If I manage to get this working I might need to look at upgrading the NAS unit and backing it up. 

Message 6 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

If I manage to get this working I might need to look at upgrading the NAS unit and backing it up. 


Putting a backup plan in place should be the first priority, though you could accomplish both by gettting a new NAS and backing up to this one.

 


@Bigmaca wrote:

 

I'm worried they won't be able to offer support for the device. If that's the case do I have any other options to get my data off the drives? I'm assuming that doing a manually mount or BTRFS file corruption is something that I can sort myself. 

 


There are some things you could do on your own.  How much experience do you have with the linux command line (ssh)?

Message 7 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red


@StephenB wrote:

@Bigmaca wrote:

If I manage to get this working I might need to look at upgrading the NAS unit and backing it up. 


Putting a backup plan in place should be the first priority, though you could accomplish both by gettting a new NAS and backing up to this one.

 


@Bigmaca wrote:

 

I'm worried they won't be able to offer support for the device. If that's the case do I have any other options to get my data off the drives? I'm assuming that doing a manually mount or BTRFS file corruption is something that I can sort myself. 

 


There are some things you could do on your own.  How much experience do you have with the linux command line (ssh)?


Agreed - if I was to purchase a new ReadyNAS system, could I just attached the drives (in the same order) and everything possibly be ok?

 

I have minimal to next to no experience in linux command line (ssh). If you're able to point me towards materials and guides I'd be happy to look. 

 

I am now in contact with support so fingers crossed they might be able to give assistance 

Message 8 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:
if I was to purchase a new ReadyNAS system, could I just attached the drives (in the same order) and everything possibly be ok?

The issue you have now is disk-related, so moving the disks won't help.  After you get past this, you can migrate the disks to other ReadyNAS models that run OS 6 firmware.  

 

However, that might not be your best option - new ReadyNAS are very hard to find, and many suspect Netgear is abandoning their NAS product line.  So you should definitely look at competing NAS.  While you wouldn't be able to directly migrate your disks, it is possible to transfer the data to/from competing NAS (generally using rsync).

 


@Bigmaca wrote:

I have minimal to next to no experience in linux command line (ssh). If you're able to point me towards materials and guides I'd be happy to look. 


Honestly, now is not the best time to learn.  Let's see if support can help.

Message 9 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

@StephenB 

 

I've finally been given the assistance to go ahead and get ProSupport but they have come back saying that they no longer support the ReadyNAS line. I now don't know what to do. My issue has been escalated to the Customer Care Team outside of ProSupport but it sounds like ReadyNAS is no longer supported. 

 

When/If I get this fixed, which I am in desperate need of. I will certainly be looking at switching systems. 

 

I've steered clear of learning ssh as a last resort. Is there any advice or assistance that you might be able to give me on this, I don't know what to do now and I would really appreciate it. 

 

I've found that I had a lot of ATA Errors on the day this happened with the unexpected power off (ATA errors haven't happened before in the logs). So sounds like your suggestion of sync/BTRFS errors might be correct. 

Message 10 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

I've finally been given the assistance to go ahead and get ProSupport but they have come back saying that they no longer support the ReadyNAS line. I now don't know what to do. My issue has been escalated to the Customer Care Team outside of ProSupport but it sounds like ReadyNAS is no longer supported. 

 


Can you follow up and ask if they are still offering Data Recovery contracts?

Message 11 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

@StephenB I've been trying throughout the day to get touch with ProSupport to ask that question.. I have not managed to get through and no one is picking up. It's now been 72hours since I last had contact with Netgear support who said they'd escalate to CCT. 

 

Sorry to ask Stephen but would it be any help to find out what's happened if I send you my logs? Is there anything else I can do?

Message 12 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

I've been trying throughout the day to get touch with ProSupport to ask that question.. I have not managed to get through and no one is picking up. It's now been 72hours since I last had contact with Netgear support who said they'd escalate to CCT. 

 


@Marc_V , @JeraldM - can you expedite?

 


@Bigmaca wrote:

 

Sorry to ask Stephen but would it be any help to find out what's happened if I send you my logs? 


You can certainly do that, though I think @rn_enthusiast would be a better option (if he is available).  Keep in mind that I am not a data recovery expert.

 

Put the full log zip file into cloud storage (drop box, icloud, google drive, etc), and send me a download link in a private message (PM).  You can send a PM by clicking on the envelope link in the upper right of the forum page.

Message 13 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

@StephenB I've just sent them over, thank you for your help. 

 

@Marc_V@JeraldM & @rn_enthusiast - any help you can give would be much appreciated. 

 

Thank you all 

Message 14 of 19
JeraldM
NETGEAR Employee Retired

Re: RN214 Shows All Volumes As Red

Hi @Bigmaca,

 

I sent you a PM regarding this concern.

 

 

Regards,

 

JeraldM

NETGEAR Community Team

Message 15 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

@StephenB @JeraldM 

 

I have attempted to organise a call with Netgear Support to sort a Pro Support contract (assuming that they still support ReadyNAS systems). They have not made contact or called since my message to them. I have no messaged them twice. 

 

Is there anything else I can do my end? 

 

I'm wondering what the next steps are to troubleshooting the device if I'm not getting help from Support. 

Message 16 of 19
JeraldM
NETGEAR Employee Retired

Re: RN214 Shows All Volumes As Red

Hi @Bigmaca,

 

It's most likely that you'll need a Data Recovery Contract; having that said, please see my last private message on how to proceed.

 

 

Regards,

 

JeraldM

NETGEAR Community Team

Message 17 of 19
Bigmaca
Aspirant

Re: RN214 Shows All Volumes As Red

This has now been resolved. 

 

After having no help with Netgear Customer service, @StephenB was able to offer fantastic assistance. I ended up needing to force a resit of the drives through a telnet terminal. There was then a need to delete chunk stream files that had been left over from Plex that where on the admin page. 

 

Thanks again StephenB. 

Message 18 of 19
StephenB
Guru

Re: RN214 Shows All Volumes As Red


@Bigmaca wrote:

Thanks again StephenB. 


Glad I was able to help.

Message 19 of 19
Top Contributors
Discussion stats
  • 18 replies
  • 4228 views
  • 0 kudos
  • 3 in conversation
Announcements