× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Backup and restore of VPD file for legacy ReadyNAS running oS6


Backup and restore of VPD file for legacy ReadyNAS running oS6

We have recently seen a rash of errors reported here on legacy machines upgraded to OS6 that are associated with a corrupt VPD (Vendor Product Data) file. This doesn't usually occur when the NAS is converted to OS6, but on a later update to OS6.10.x. This results in an unbootable unit, and USB recovery will not fix it. Thus, I have recognized that owners of legacy units running OS6 would be well served to backup their VPD for potential future recovery. Even if you're still running OS4.2.x, it's probably not a bad idea. Lots of users never run into this issue, but this is what you can do now in case it does affect you at some point.


The VPD is an encrypted file in the boot flash that contains the model and serial number of your NAS. It lets the OS know how to configure your unit, and it's probably encrypted to keep meddlers from messing with it and anyone from trying to create a "do it yourself ReadyNAS". Thus, it's unique to your unit and can't be re-created by anyone other than Netgear. While the forum mods have been helpful for many by creating a replacement, there is no guarantee they will be able to continue doing so.


Note that this is not applicable to native OS6 units -- they use another method to ID the hardware that's more robust.


In a standard boot (except in rack-mount units that use a USB drive for their flash), the boot flash is unavailable. But it is available in tech support mode in both OS4.2.x and OS6. The procedure is nearly the same for each, so this will cover both. If you are about to upgrade from OS4.2.x to OS6, then I recommend you back up your VPD first. If you have already completed the conversion, then do it before you apply another OS update.


For this, we'll save the VPD on a USB flash drive. It must be formatted as FAT, FAT32, or EXT with just one partition. Also make sure it doesn't have a boot sector. I recommend you have at least one file on it so you can properly ID that it's mounted. Note that I've tried with a couple flash drives, up to 32GB, with success.


Step one is to boot into tech support mode using the reset button boot menu. For units running OS4.2.x, do so with the USB drive already inserted. Start here to determine how to access the boot menu on your unit: ReadyNAS-ReadyDATA-Boot-Menu .


Now, you have to telnet into the unit. If you normally use a static IP assigned in the NAS, the NAS may not be at that address. If you reserve an address in your router, it should be. If it's not where you expect it to be, use RAIDar to determine the IP address. I use PUTTY for a telnet client, but you can use whatever you want to. Log in as user root with password infr8ntdebug.


If you are running OS6 and didn't boot with the USB inserted, insert it now.


If your unit is a 2-drive unit (as was the Pro2 I tested this on), the two hard drives will be /dev/sda and /dev/sdb. Then /dev/sdc will be the unit flash and /dev/sdd will be the USB drive. If you have more drives (actual drives, not empty slots), they'll be the next two (so sdg and sdh on a 6-drive unit). We'll be mounting the first partition of each.


On an OS6 machine, you have to move to the root directory: CD /


Now you can mount the internal flash: mount  /dev/sdc1  mnt (or whatever is the right sd_1 device for your NAS).
Verify the contents of flash are there: ls  mnt will return something like this:

csums.md5     kernel.up     root.tlz      version.txt
initrd.gz     ldlinux.sys   supplmnt.tlz  vpd
kernel        memtest       syslinux.cfg


It'll be a bit different on an OS6 unit, but the big thing is that vpd is there.


Next, we'll make a directory to which we can mount the USB, do the mount, and check that it worked:

mkdir  usb
mount  /dev/sdd1  usb  (again, or appropriate sd_1 device for your NAS)
ls  usb


This is where having something already on the USB helps. You'll see it in the results.


Now, we just copy the VPD. If you're backing up, do cp  /mnt/vpd  /usb. If recovering, do the opposite: cp  /usb/vpd  /mnt and verify with ls  usb or ls  mnt.


Then unmount the USB with umount  usb and remove the USB drive. Now you can do a normal boot.


Put a copy of the file somewhere you'll not misplace it. On the NAS itself is OK only if you also do a backup that'll include it and can be accessed without the NAS. When you need it, you won't have access to the NAS.


Note that I don't recommend you use this method to backup and restore anything else. Leave that to USB recovery.


If anyone knows how to mount a USB drive not present at boot on OS4.2.x, please add that information. I gave up trying since I had a work-around.  If added afterward, it shows up in dmesg, but not /dev.


If you only found this because you already lost your VPD, I don't recommend you copy one from another identical machine and you absolutely should not from another machine type. They'll end up showing the same serial number or worse.  Ask the mods to help you create and install a replacement.

Message 1 of 3

Re: Backup and restore of VPD file for legacy ReadyNAS running oS6

After happily recovering my Ultra 6 and then getting it back on version 6.9.5 Hotfix 1, as per the new owner's wish, I've selected to be notified on LTS updates only. I think main reason is to be able to expand storage beyond the current 6 * 4 TB.
It keeps offering me 6.9.6 and I've followed your advice to backup VPD. Would you consider 6.9.6 a relatively safe version to upgrade to, just to get rid of the reminders or just keep cancel the update reminders to remain on 6.9.5 Hotfix 1? I notice you say the corruption happens mostly with 6.10.x releases...

Message 2 of 3

Re: Backup and restore of VPD file for legacy ReadyNAS running oS6

I've been running 6.9.6 for about 2 years.  I'm not a first adopter on my main and backup NAS, I have a couple "sandbox" NAS for that.  But given how long it's been since the LTS string got any security update, I'm likely to move to 6.10.8 on all.  I think others have been running it long enough that's it's proven stable.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 8 kudos
  • 2 in conversation