× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: apt.readynas.com - Broken repo?

Gregsta
Aspirant

apt.readynas.com - Broken repo?

I'm seeing 403 errors when attempting to install any package on a Readynas device running v6.10.8 firmware. 

The 403 Access Denied error is seen if I attempt to access the URLs in my own web browser.

 

https://apt.readynas.com/packages/readynasos/dists/6.10.8/apps/pool/t/transmission/transmission_2.82...

 

Is the issue with the web server permissions or is my Readynas supposed to have some sort of key/certificate to authenticate and that's what is missing here? 

 

root@steammills:~# apt install transmissionr6
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
transmission
The following NEW packages will be installed:
transmission transmissionr6
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,526 kB of archives.
After this operation, 3,528 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 https://apt.readynas.com/packages/readynasos 6.10.8/apps amd64 transmission amd64 2.82-1
403 Forbidden
Err:2 https://apt.readynas.com/packages/readynasos 6.10.8/apps amd64 transmissionr6 all 3.00.8
403 Forbidden
E: Failed to fetch https://apt.readynas.com/packages/readynasos/dists/6.10.8/apps/pool/t/transmission/transmission_2.82-1_amd64.deb 403 Forbidden

E: Failed to fetch https://apt.readynas.com/packages/readynasos/dists/6.10.8/apps/pool/t/transmissionr6/transmissionr6_3.00.8_all.deb 403 Forbidden

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

 

Message 1 of 17

Accepted Solutions
hac_sysmon
Aspirant

Re: apt.readynas.com - Broken repo?

Hi @Anisha,
I'm currently at 6.10.8 still as I'm hesitant to go to 6.10.9 as long as it is not offered through the dashboard.
Thanks for looking into that repo.

View solution in original post

Message 15 of 17

All Replies
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@Gregsta wrote:

I'm seeing 403 errors when attempting to install any package on a Readynas device running v6.10.8 firmware. 

The 403 Access Denied error is seen if I attempt to access the URLs in my own web browser.


Yes.  I've looped in a mod ( @AnishaA ) but nothing has been fixed yet.

 

You can get download the deb manually from https://apps.readynas.com/pages/?page_id=9  Upgrading to 6.10.9 will also let you get the packages.

 

But there are other recent issues because Debian 8 (Jessie) has been archived by the Debian folks.  @Sandshark identifed the changes needed in the first post here:

Message 2 of 17
AnishaA
NETGEAR Moderator

Re: apt.readynas.com - Broken repo?

Hello @Gregsta ,

 

Yes, there is a possibility that the SSH configuration issue that might be a hinder to installing packages. 

 

You can refer to this kb article to check for the right configuration and make changes accordingly.

 

https://kb.netgear.com/30068/ReadyNAS-OS-6-SSH-access-support-and-configuration-guides 

 

As far as we know there is no particular key for installing packages, and have you tried any other application to install and you get the same error?

 

If not then please try installing other apps to confirm whether the issue.

 

As @StephenB  mentioned you can upgrade to the latest firmware which could resolve this issue.

 

Also, try the URL with a different browser once.

 

If your issue is resolved please close the thread by clicking "Accept as solution".

 

 

 

 

 

Message 3 of 17
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@AnishaA wrote:

 

Also, try the URL with a different browser once.

 


That won't help.  

 

The issue is that the 6.10.8 repository either doesn't include the apps pool folder at all, or it doesn't have the needed permissions to access it.

 

The app package lists in binary-amd64, binary-armel, and binary-armhf are accessible, but not the actual files in pool 

 

The updates pool folder is also not accessible, so it has the same problem. The main pool folder is accessible.

 

 

Message 4 of 17
Gregsta
Aspirant

Re: apt.readynas.com - Broken repo?

I see what you mean, with the 6.10.8 repo having the issue but not the 6.10.9 repo. 
https://apt.readynas.com/packages/readynasos/dists/6.10.8/apps/pool/t/transmission/transmission_2.82...

https://apt.readynas.com/packages/readynasos/dists/6.10.9/apps/pool/t/transmission/transmission_2.82... 

 

Just out of interest, what type of repo is this? Does it point remotely to another repo? Not sure if this is a YUM repo or a different type of repo, so just curious. 

I'm aware of the issue with the Jessie packages being archived. That is partially why I am here. I was struggling to compile some custom packages to make use of some Python modules but eventually gave up as I was struggling to install so many dependencies and couldn't seem to install keys that would give me access to the archived repos. 

Message 5 of 17
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@Gregsta wrote:

Just out of interest, what type of repo is this? Does it point remotely to another repo? Not sure if this is a YUM repo or a different type of repo, so just curious. 


Not sure how it is built.

 


@Gregsta wrote:


I'm aware of the issue with the Jessie packages being archived. That is partially why I am here. I was struggling to compile some custom packages to make use of some Python modules but eventually gave up as I was struggling to install so many dependencies and couldn't seem to install keys that would give me access to the archived repos. 


You should be able to mirror them using apt-mirror, and then just use the mirror.  If you look further into the thread I posted above, you'll see some conversations on that.

 

Message 6 of 17
hac_sysmon
Aspirant

Re: apt.readynas.com - Broken repo?

I encountered this problem when trying to install plexmediaserver from the dashboard. I ended up trying htop from the commandline as it is a simple package and then noticed why it failed; any install attempt fails with the same:

 

# apt install htop
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
htop
0 upgraded, 1 newly installed, 0 to remove and 32 not upgraded.
Need to get 92.9 kB of archives.
After this operation, 160 kB of additional disk space will be used.
Err:1 https://apt.readynas.com/packages/readynasos 6.10.8/apps amd64 htop amd64 1.0.0
403 Forbidden
E: Failed to fetch https://apt.readynas.com/packages/readynasos/dists/6.10.8/apps/pool/h/htop/htop_1.0.0_amd64.deb 403 Forbidden

 

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

 

I'm on a ReadyNAS 314 with firmware 6.10.8.

You refer to firmware 6.10.9 but my NAS says I'm on the latest version when I check for updates.

Any thoughts?

TIA

Message 7 of 17
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@hac_sysmon wrote:

 

You refer to firmware 6.10.9 but my NAS says I'm on the latest version when I check for updates.

 


Because it was just released.  You can manually install it from here:

Message 8 of 17
hac_sysmon
Aspirant

Re: apt.readynas.com - Broken repo?

Thanks. As it wasn't shown in the dashboard I wasn't sure it was safe to do so.
Message 9 of 17
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@hac_sysmon wrote:
Thanks. As it wasn't shown in the dashboard I wasn't sure it was safe to do so.

There is a lag of 1-2 weeks after release before they push out the the update.  They've never said why, but it is possible that they are looking for early feedback.

 

I did install it on my test RN102, but nothing else yet.

Message 10 of 17
Gregsta
Aspirant

Re: apt.readynas.com - Broken repo?

I followed those instructions but see all these kind of errors. Why does apt-get attempt to install the deb8u1 version of these packages if deb8u2 is already installed?  This type of error is seen for most package installs. 

root@steammills:/data# apt-get install gcc-4.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc-4.9 : Depends: cpp-4.9 (= 4.9.2-10+deb8u1) but it is not going to be installed
           Depends: gcc-4.9-base (= 4.9.2-10+deb8u1) but 4.9.2-10+deb8u2 is to be installed
           Depends: libgcc-4.9-dev (= 4.9.2-10+deb8u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 

Message 11 of 17
AnishaA
NETGEAR Moderator

Re: apt.readynas.com - Broken repo?

Hello @Gregsta 

 

When you unmet the dependencies you get this kind of error. It's possible that the repositories you are using do not contain the necessary packages or have not been updated to include the specific versions required.

 

You can try 

 

sudo apt-get update

 

 this will refresh the page and retrieve the info on the packages.

 

You can also try 

 

sudo apt-get install -f

this may rectify and fix the broken package error.

 

Please try with both commands once.

 

Have a lovely day, 
Anisha A
Netgear Team 

 

Message 12 of 17
hac_sysmon
Aspirant

Re: apt.readynas.com - Broken repo?

@Anisha
The 403 errorrand the repo access is misconfigured in the Netgear website. Needs fixing by Netgear and should be a simple fix.
Why is that taking so long?

Also, the new firmware still is not presented in my dashboard. It was mentioned here there's usually a 2 to 3 weeks delay but it's a lot longer by now. Are there issues with it preventing it from becomming GA?

Thanks.
Message 13 of 17
AnishaA
NETGEAR Moderator

Re: apt.readynas.com - Broken repo?

Hello @hac_sysmon ,

 

What is the current firmware version you are using currently?

 

We will check from our end for an update on the repo access.

 

Have a lovely day, 
Anisha A
Netgear Team 

 

 

 

 

Message 14 of 17
hac_sysmon
Aspirant

Re: apt.readynas.com - Broken repo?

Hi @Anisha,
I'm currently at 6.10.8 still as I'm hesitant to go to 6.10.9 as long as it is not offered through the dashboard.
Thanks for looking into that repo.
Message 15 of 17
StephenB
Guru

Re: apt.readynas.com - Broken repo?


@hac_sysmon wrote:
I'm currently at 6.10.8 still as I'm hesitant to go to 6.10.9 as long as it is not offered through the dashboard.


I'm running it on two NAS (arm and x86) with no issues.

 

Note you can downgrade back to 6.10.8 if needed.

Message 16 of 17
good4y0u
Star

Re: apt.readynas.com - Broken repo?

Here is a 2024 Solution: It is tested working by me.
When I ran apt update and upgrade I was finally able to get things working without key errors etc.
My question for the group here: what can/should I remove at this point from the mirror/sources lists.

I updated my Sources to:
 

cat /etc/apt/sources.list
deb https://apt.readynas.com/packages/readynasos 6.10.8 updates apps main
deb https://apt.readynas.com/packages/readynasos 6.10.7 updates apps main
# deb http://mirrors.kernel.org/debian jessie main
# deb http://security.debian.org/ jessie/updates main
deb [trusted=yes] http://archive.debian.org/debian/ jessie main
deb [trusted=yes] http://archive.debian.org/debian-security jessie/updates main

deb [trusted=yes] http://archive.kernel.org/debian-archive/debian jessie main contrib non-free
deb [trusted=yes] http://archive.kernel.org/debian-archive/debian jessie-backports main contrib non-free


I am using Mirror as well (300 gigs)

root@NETGEAR-NAS:/home/machine# cat /etc/apt/mirror.list
############# config ##################
#
# set base_path    /var/spool/apt-mirror
set base_path    /home/machine/apt-mirror
#
# set mirror_path  $base_path/mirror
# set skel_path    $base_path/skel
# set var_path     $base_path/var
# set cleanscript $var_path/clean.sh
# set defaultarch  <running host architecture>
# set postmirror_script $var_path/postmirror.sh
# set run_postmirror 0
set nthreads     20
set _tilde 0
#
############# end config ##############

deb http://ftp.us.debian.org/debian unstable main contrib non-free
deb-src http://ftp.us.debian.org/debian unstable main contrib non-free
##start custom
deb https://apt.readynas.com/packages/readynasos 6.10.8 updates apps main
deb https://apt.readynas.com/packages/readynasos 6.10.7 updates apps main
#deb http://mirrors.kernel.org/debian jessie main
#deb http://security.debian.org/jessie/updates main
deb http://archive.debian.org/debian/ jessie main
deb http://archive.debian.org/debian-security jessie/updates main

deb http://archive.kernel.org/debian-archive/debian jessie main contrib non-free
deb http://archive.kernel.org/debian-archive/debian jessie-backports main contrib non-free

##end custom
# mirror additional architectures
clean http://ftp.us.debian.org/debian

 

Message 17 of 17
Top Contributors
Discussion stats
  • 16 replies
  • 4964 views
  • 5 kudos
  • 5 in conversation
Announcements